Port Bug 1262731 to Thunderbird (/mail /im): Don't use a separate ICU data file on Windows.

RESOLVED DUPLICATE of bug 1288471

Status

Thunderbird
General
--
blocker
RESOLVED DUPLICATE of bug 1288471
2 years ago
2 years ago

People

(Reporter: Jorg K (GMT+1), Unassigned)

Tracking

Trunk

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Bug 1262731 needs to be ported otherwise make installer will not work because of a missing icu data file.

Our SM friends fixed it for themselves but not for us. Thanks for the cooperation :-(
https://hg.mozilla.org/comm-central/rev/201d96fc882008a8a9ef006d990c19d955cdc93b

See:
https://dxr.mozilla.org/comm-central/search?q=DMOZ_ICU_DBG_SUFFIX&redirect=false
I can land the patch when needed.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1288471
Jorg that's unfair. I asked yesterday in maildev if TB is affacted after seeing an earlier conversation that its not. Didn't get an answer or I would have gladly fixed it for you too.

http://logs.glob.uno/?c=mozilla%23maildev&s=21+Jul+2016&e=22+Jul+2016
Resolution: DUPLICATE → FIXED
Sorry accidently delete the duplicate
Resolution: FIXED → DUPLICATE
Duplicate of bug: 1288471
(Reporter)

Comment 4

2 years ago
(In reply to Frank-Rainer Grahl from comment #2)
> Jorg that's unfair. I asked yesterday in maildev if TB is affacted after
> seeing an earlier conversation that its not. Didn't get an answer or I would
> have gladly fixed it for you too.
Yes, I saw this go past on IRC while working on a 4422 line patch to fix other bustage in bug 1288355. Since I don't know anything about packaging and the description of bug 1262731 doesn't really relate to it, I paid no attention.

Frankly, you could have seen that TB and IM were affected:
https://dxr.mozilla.org/comm-central/search?q=DMOZ_ICU_DBG_SUFFIX&redirect=false
and rattled the cage a little harder. When we make changes we know affect you, we fix SM too or at least NI you. A line on IRC easily gets overlooked/ignored.

Anyway, cooperation is generally good, so excuse the words stemming from disappointment.
Well its summertime and Seamonkey people are mostly absent right now. I struggled with two other bugs and was happy to get them resolved in time for a new nightly. Just to reassure you that it wasn't intentional to left TB alone out in the cold dark world  :)

I would love to have a generic comm-central bug component for these bugs. I am quite sure these bugs which affect all c-c apps will happen more often in the future. We already had a few in the last months. Maybe we should discuss it in irc.
You need to log in before you can comment on or make changes to this bug.