location bar: address is not updated if entered manually

RESOLVED DUPLICATE of bug 1287078

Status

SeaMonkey
Location Bar
RESOLVED DUPLICATE of bug 1287078
2 years ago
2 years ago

People

(Reporter: lvm, Unassigned)

Tracking

SeaMonkey 2.45 Branch
Unspecified
Windows 7

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:48.0) Gecko/20100101 Firefox/48.0 SeaMonkey/2.45
Build ID: 20160714190830

Steps to reproduce:

Type 'bugzilla.mozilla.org' in the address field of navigation bar and press enter - the title page of this site is opened, address in navigation bar remains exactly as entered - 'bugzilla.mozilla.org', actually it should change to 'https://bugzilla.mozilla.org/'.
Click on 'New' - address should change to 'https://bugzilla.mozilla.org/enter_bug.cgi' but it remains 'bugzilla.mozilla.org'.
Go to an arbitrary address from the bookmarks - address won't change.

Also can be reproduced if initial address is picked from LRU picklist of the navigation bar, but not for addresses selected from the bookmarks. Other tabs are not affected but may be screwed up independently.

Comment 1

2 years ago
OS due to original report!

Probably a DUP of "Bug 1287078 - Location Bar contents not updated when opening new page in the same TAB by link, History or bookmark", what itself is a DUP of "Bug 1272401 - Port Firefox Bug 1241085 Parts 2 and 3, and maybe 4 This should fix SeaMonkey Bug 1270848 - Back and Forward buttons unavailable ".

@Reporter: Thank you for your attention. 
Please feel free to reopen this Bug if you find out that the fix for the other bug does not solve your problem or if you see other well founded indication that you fond an independent bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
OS: Unspecified → Windows 7
Resolution: --- → DUPLICATE
Summary: navigation bar address is not updated if entered manually → location bar: address is not updated if entered manually
Duplicate of bug: 1287078
You need to log in before you can comment on or make changes to this bug.