Mozilla crashes if you are switching between classic and modern theme often

RESOLVED INVALID

Status

--
critical
RESOLVED INVALID
17 years ago
10 years ago

People

(Reporter: bastiaf, Assigned: hewitt)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:0.9.8) Gecko/20020214
BuildID:    20020304

If I switch between classic and modern often theme with View/Apply Theme,
Mozilla crashs with the message

./run-mozilla.sh: line 72:  1791 Segmentation fault      $prog ${1+"$@"}

Sometimes Mozilla crashs after 3 times, sometimes after 10.

The same problem is in Mozilla 0.9.8 (20020214), but I dont know the message.

Reproducible: Always
Steps to Reproduce:
1. View/Apply Theme Classic
2. View/Apply Theme Modern
3. Step 1 to 3 again until Mozilla crashs

Actual Results:  Mozilla 0.9.8 crashs

Mozilla 20020304 crashs with
./run-mozilla.sh: line 72:  1791 Segmentation fault      $prog ${1+"$@"}

Comment 1

17 years ago
There are already several crashers on theme switching (e.g. bug 116038, bug
121638, bug 124009, bug 124205 and bug 125518) 

A stack trace/talkback report would help considerably in figuring out whether
this is a duplicate of one of those, of another that I missed, or a new bug.
Severity: major → critical
Summary: Mozilla crashs if you are switching between classic and modern theme often → Mozilla crashes if you are switching between classic and modern theme often
If this is still out of hand around 1.0, would the old 'theme change on browser
restart' that was in older builds be a sufficient workaround?

Comment 3

17 years ago
I am closing this as invalid[1] due to lack of details.

Reporter:  If you are able to generate a talkback incident or stack trace,
please re-open this bug and attach relevant details.

[1] sorry if "invalid" sounds harsh, but it's all bugzilla's got.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.