Closed Bug 1288688 Opened 4 years ago Closed 4 years ago

Empty username on accounts.firefox.com notification panel after changing the password

Categories

(Toolkit :: Password Manager, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1288721
Tracking Status
firefox47 --- affected
firefox48 --- affected
firefox49 --- affected
firefox50 --- affected

People

(Reporter: petruta.rasa, Unassigned)

References

Details

[Note]:
- This only reproduces if the account's username and password were not previously saved

[Affected versions]:
- Firefox 48 beta 10
- latest Aurora 49.0a2 (2016-07-21)
- latest Nightly 50.0a1 (2016-07-21)

[Affected platforms]:
- Ubuntu 14.04 64-bit
- Mac OS X 10.10.1
- Windows 7 64-bit

[Steps to reproduce]:
1. Sign in to Sync with an existing account	
2. Go to about:preferences#sync, and click "Manage Account"
3. Click "Change" button for the "Password" field
4. Enter the old and the new password and click "Change"
5. Firefox prompts to save the username and password 	

[Expected result]:
- The notification panel contains the username and the password

[Actual result]:
- Username field is empty

[Regression range]:
- This issue is not a regression; it reproduces back to Firefox 41.0.2.
Also, on Firefox 30, where the notification didn't contained the username and passwords fields, choosing to remember them, would save an empty username.
This was fixed by bug 1288721 with an FxA server change as there was nothing better the password manager could do.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1288721
You need to log in before you can comment on or make changes to this bug.