Link error gfxFontconfigFontBase::gfxFontconfigFontBase (Thunderbird Linux build busted 2016-07-22)

RESOLVED FIXED in Firefox 50

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jorgk, Assigned: lsalzman)

Tracking

Trunk
mozilla50
x86_64
Linux
Points:
---

Firefox Tracking Flags

(firefox50 fixed)

Details

(Reporter)

Description

2 years ago
First seen 2016-07-22:
https://treeherder.mozilla.org/#/jobs?repo=comm-central&revision=f99d81cd24ed63791b6fa0359c596d435fdce35c

http://archive.mozilla.org/pub/thunderbird/tinderbox-builds/comm-central-linux64/1469186185/comm-central-linux64-bm74-build1-build61.txt.gz

says:

Link error:
../../gfx/thebes/gfxFcPlatformFontList.o: In function `gfxFontconfigFontEntry::CreateFontInstance(gfxFontStyle const*, bool)':
/builds/slave/tb-c-cen-l64-00000000000000000/build/mozilla/gfx/thebes/gfxFcPlatformFontList.cpp:920: undefined reference to `gfxFontconfigFontBase::gfxFontconfigFontBase(_cairo_scaled_font*, _FcPattern*, gfxFontEntry*, gfxFontStyle const*)'
../../gfx/thebes/gfxFontconfigFonts.o: In function `gfxFcFont::gfxFcFont(_cairo_scaled_font*, _FcPattern*, gfxFcFontEntry*, gfxFontStyle const*)':
/builds/slave/tb-c-cen-l64-00000000000000000/build/mozilla/gfx/thebes/gfxFontconfigFonts.cpp:1666: undefined reference to `gfxFontconfigFontBase::gfxFontconfigFontBase(_cairo_scaled_font*, _FcPattern*, gfxFontEntry*, gfxFontStyle const*)'

Looks like:
http://hg.mozilla.org/mozilla-central/log/tip/gfx/thebes/gfxFcPlatformFontList.cpp

Bug 1287552:
Strange, what seems to be missing was added here:
https://hg.mozilla.org/mozilla-central/rev/df5b884bc592#l17.30

Lee, any hints for us?
Flags: needinfo?(lsalzman)
(Assignee)

Comment 1

2 years ago
The gfxFontconfigFontBase constructor in gfxFontconfigUtils.cpp somehow ended up inside the scope of an #ifdef it shouldn't have. I'll push a fix to inbound as soon as the tree opens again (closed right now).
Flags: needinfo?(lsalzman)
(Reporter)

Comment 2

2 years ago
Thanks, Lee.

Comment 3

2 years ago
Pushed by lsalzman@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d398365c915
Fix gfxFontconfigFontBase constructor. r=me
(Reporter)

Updated

2 years ago
Component: General → Graphics
Product: Thunderbird → Core
(Reporter)

Updated

2 years ago
Assignee: nobody → lsalzman
Blocks: 1287552
(Reporter)

Updated

2 years ago
Summary: Thunderbird Linux build busted 2016-07-22 → Link error gfxFontconfigFontBase::gfxFontconfigFontBase (Thunderbird Linux build busted 2016-07-22)
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1288832

Updated

2 years ago
Duplicate of this bug: 1288878

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/0d398365c915
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox50: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
You need to log in before you can comment on or make changes to this bug.