If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

browser.engagement.total_uri_count Not being calculated

RESOLVED INVALID

Status

()

Toolkit
Telemetry
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: Silne30, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
STR

1.) Build Firefox from trunk
2.) Navigate to about:telemetry page
3.) Click to show Scalars information
4.) Open a new tab and navigate to http://www.mozilla.org
5.) Refresh about:telemetry page

Expected Result:
In scalars dropdown you should see browser.engagement.total_uri_count show a value of 1

Actual Result: browser.engagement.total_uri_count Never shows up under Scalars nor does a value.
(Reporter)

Comment 1

a year ago
Based on our docs, I think this was tested properly unless I misunderstood the triggering event. Other scalars were showing up properly.
Flags: needinfo?(gfritzsche)
That sounds bad :(

I tried the STR here with a fresh clone from trunk and I cannot reproduce the problem locally. Are you on the latest revision?

browser.engagement.total_uri_count just landed yesterday (so you might need to pull the latest changeset from m-c) and I just verified that it was shipped in Nightly as well (in case you want to test from that instead of building off trunk).
We should test this in Nightly now and see if it works.
Flags: needinfo?(gfritzsche) → needinfo?(jdorlus)
(Reporter)

Comment 4

a year ago
Tested this in nightly. It does work. It was very possible that I didn't have the proper changes. Should I close this as not a bug or something like that?
Flags: needinfo?(jdorlus)
Yes, lets close this one.

It was probably from either not having the newest sources or a missing setting in your builds config.
For testing, our release builds should be what we focus on.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.