compare-locales is not being run for lightning

RESOLVED WORKSFORME

Status

--
blocker
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: martin.u, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160601155443

Steps to reproduce:

Start Thunderbird Version 45.2.0 and open the integrated Lightning calendar; try to create or edit appointments


Actual results:

This bug, essentially: https://bugzilla.redhat.com/show_bug.cgi?id=1330427
It may be a regression.


Expected results:

I would like to have a proper UI rendering, which is still working in 38.8.0 (to which I had to revert).

Comment 1

2 years ago
Do you experience this with the distro package of TB only or also with the Mozilla distributed TB binary?

By reading the referenced bug, it seems to be only an issue with the former. In that case, please report this to your distribution's (Fedora?) bug tracker as this would be nothing that we can resolve.

If this is (also) an issue with the Mozilla distributed TB binary, please check whether this is also an issue with all addons except of Lightning disabled. If the issue still remains, we should move this bug to calendar.
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 2

2 years ago
"XML Parsing Error: undefined entity" might indicate that a string is missing. Is this a localized version, i.e., not the default English(US) one? If yes, it may be a localization problem.
(Reporter)

Comment 3

2 years ago
Yes, it is a localization problem. I just confirmed that en-US works fine while en-GB does not.

Comment 4

2 years ago
Let's move this to en-GB for confirmation.
Assignee: nobody → moz_en-gb
Component: Untriaged → en-GB / English (United Kingdom)
Product: Thunderbird → Mozilla Localizations
QA Contact: moz_en-gb
Version: 45 Branch → unspecified

Comment 5

2 years ago
The error from the Redhat bugzilla is:
XML Parsing Error: undefined entity
Location: chrome://calendar/content/calendar-event-dialog.xul
Line Number 1216, Column 23:                      <checkbox id="notify-attendees-checkbox"
----------------------^
The two entities on that xul are:
event.attendees.notify.label
event.attendees.notify.accesskey
It is the latter that is missing.
Usually any missing entities are substituted by the en-US equivalent, but that doesn't seem to be the case for Lightning.
The relevant patches are on Bug 1252308 and Bug 1249850, and I am happy to land them on ESR-45 if someone tells me the best branch to land them on (as there are two - one for Firefox and one for Thunderbird - see http://hg.mozilla.org/releases/l10n/mozilla-release/en-GB/graph for details)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(rkent)

Updated

2 years ago
OS: Linux → All
Hardware: x86_64 → All
Target Milestone: --- → mozilla45
Looking at http://ftp.mozilla.org/pub/thunderbird/candidates/45.2.0-candidates/build1/logs/release-comm-esr45-linux64_repack_3-bm70-build1-build0.txt.gz it seems that compare-locales is not being run for lightning. I don't know if it is related to IOError: [Errno 2] No such file or directory: '../../dist/bin/application.ini' but we should definitely be running this, it could well be that a lot more locales are broken in this way.

We may want to respin or do a .1 build for this once fixed.
Assignee: moz_en-gb → nobody
Component: en-GB / English (United Kingdom) → Build Config
Flags: needinfo?(rkent)
Product: Mozilla Localizations → Thunderbird
QA Contact: moz_en-gb
Target Milestone: mozilla45 → ---
Fallen	wsmwk: I recall hearing from another bug about application.ini not being generated and I think that was closer to resolution, so it may be fixed with that
Fallen	the impact is the yellow box of death for locales that are not fully translated.

A. what population of users is impacted?
B. aleth can you look into what might be causing this?
Flags: needinfo?(aleth)
(Reporter)

Comment 8

2 years ago
Version 45.3.0 fixes this issue for me.

Comment 9

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #7)
> B. aleth can you look into what might be causing this?

Calendar has some special sauce for compare-locales here:
https://dxr.mozilla.org/comm-central/source/calendar/lightning/lightning-packager.mk#105

I don't know why it broke.
Flags: needinfo?(aleth)

Updated

2 years ago
Component: Build Config → Build Config
Product: Thunderbird → Calendar
Summary: Lightning UI: XML Parsing Error in 45.2.0 → compare-locales is not being run for lightning
can anyone else confirm martin's comment that this is no longer a problem?

rkent, fallen has suggested we wait for this to be fixed before building 45.4.0
Severity: normal → blocker

Comment 11

2 years ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #10)
> can anyone else confirm martin's comment that this is no longer a problem?

I suspect that means the string has been added for martin's locale, but not necessarily that compare-locales is running properly for calendar.
I recall hearing about a bug related to application.ini, but I don't remember which one that is. I do have hopes that this one fixed itself automatically, but it would be great if someone has time to reproduce the error locally. It should just be a matter of executing the repacks targets. It may also make sense to check if this was already fixed in 45.3.0, or we could even build 45.4.0 and hope it works, then fix if necessary.

Comment 13

2 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #12)
> I recall hearing about a bug related to application.ini, but I don't
> remember which one that is.

The most recent application.ini bug was too recent to affect 45.

Comment 14

2 years ago
(In reply to Philipp Kewisch [:Fallen] from comment #12)
> It may also make sense to check if this was already fixed in 45.3.0, or we
> could even build 45.4.0 and hope it works, then fix if necessary.

If you already know what to expect, can't you just check https://ftp.mozilla.org/pub/thunderbird/candidates/45.3.0-candidates/build1/logs/release-comm-esr45-win32_repack_3-bm71-build1-build0.txt.gz ?

Comment 15

2 years ago
The 45.3 log has at least the same IO error mentioned in comment 6, so if that is the root cause it's probably not fixed yet. But if there haven't been bugs for other locales, it has probably no further impact on 45 if en-gb has fixed the issue in their locale.
Repacks look like compare-locales is running now, closing.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.