Closed Bug 1288846 Opened 6 years ago Closed 3 years ago

Inspector panel blank after refreshing page on aframe.io

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: jlong, Unassigned)

References

Details

STR:

1. Go to https://aframe.io/
2. Inspect the canvas element (the "A" and the sky)
3. See the `a-sky` and other sibling elements of the canvas
4. Delete `a-sky` (right click -> delete)
5. Refresh the page

The inspector panel is blank.
We get the following stack trace when reloading the page:

getTopWindow@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/layout/utils.js:33:18|
isTopWindow@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/layout/utils.js:58:35|
getFrameElement@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/shared/layout/utils.js:121:3|
WalkerActor<._childOfWindow@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/inspector.js:2394:13|
WalkerActor<.onFrameUnload@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/inspector.js:2407:11|
[...]
_willNavigate@resource://gre/modules/commonjs/toolkit/loader.js -> resource://devtools/server/actors/webbrowser.js:1962:5|

Looks like onFrameUnload, the inspector actor tries to release all orphan nodes and this fails when one of the orphan nodes is a Custom Element.

Inspector bug triage, filter on CLIMBING SHOES.
Priority: -- → P2
See Also: → 983386
I wasn't able to reproduce this bug on nightly. May this bug be fixed by one of my patches to get rid of blank inspectors? I haven't fixed anything regarding any issues with Custom element, but I possibly changed the behavior of onFrameLoad and onFrameUnload
See Also: → 1461893
Product: Firefox → DevTools

This now works ok.

No longer blocks: top-inspector-bugs
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.