Closed Bug 1288854 Opened 7 years ago Closed 6 years ago

Pressing "escape" to cancel the eye dropper does not always cancel it

Categories

(DevTools :: Inspector, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1289433

People

(Reporter: moby, Assigned: evanxd)

References

Details

(Keywords: regression)

* Click the eye dropper icon
* Immediately press escape

Expected behavior: The eye dropper disappears
Actual behavior: The eye dropper does not disappear

I suspect this is because the keydown event is being listened for from the highlighter context, and clicking on the icon to open the eye dropper focuses on the inspector context. Pressing escape with the inspector context focused toggles the split console.
Assignee: nobody → evan
Status: NEW → ASSIGNED
Probably a duplicate of Bug 1289433.

Inspector bug triage, filter on CLIMBING SHOES.
Keywords: regression
Priority: -- → P2
See Also: → 1289433
I think I fixed that issue in bug 1289433's patch.
Hi Alexandre,

Yes, the patch[1] you're working on fixed the bug. So let set as duplicate of Bug 1289433.

Thanks for the fix.

[1]: https://bug1289433.bmoattachments.org/attachment.cgi?id=8778932
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.