Generate JSDocs from WebExtensions code

RESOLVED DUPLICATE of bug 1423425

Status

P3
normal
RESOLVED DUPLICATE of bug 1423425
2 years ago
4 months ago

People

(Reporter: andy+bugzilla, Unassigned)

Tracking

48 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: docs, triaged)

(Reporter)

Description

2 years ago
In bug 1278733 JS Doc validity was enforced. We should now look at generating the JS Docs. Luca do I remember you having something for this?

Updated

2 years ago
Priority: -- → P3
Whiteboard: docs, triaged
Flags: needinfo?(lgreco)

Comment 1

6 months ago
Marking as a duplicate of Bug 1423425, the jsdoc comments are now being read by sphinx-js and linked to the docs generated from the rst doc files, e.g. https://firefox-source-docs.mozilla.org/toolkit/components/extensions/webextensions/reference.html
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Flags: needinfo?(lgreco)
Resolution: --- → DUPLICATE
Duplicate of bug: 1423425

Updated

4 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.