With title bar enabled, a link opened in a new window via the target attribute has the bottom of the page cut off (including the scroll bar)

RESOLVED DUPLICATE of bug 1269462

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 1269462
a year ago
a year ago

People

(Reporter: Chris Cloutier, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160604131506

Steps to reproduce:

When you have the Title Bar enabled, and a web page you're on opens a link in a new window, then the bottom of that newly-opened window/page is cut off (page content and scroll bar control).

I have experienced this for a long time, on Windows XP and Windows 7 Professional, but just now determined that it is caused by enabling the title bar.

Please note, this is not the same bug as Bug 1235434.

To reproduce this bug, perform the following steps:

1.  In Options > General, uncheck "Open new windows in a new tab instead".
2.  In Customize, enable the Title Bar.
3.  Open URL "http://www.w3schools.com/tags/tryit.asp?filename=tryhtml_a_target".
4.  Click the "Visit W3Schools!" link in the right pane of the page.



Actual results:

When the link is opened in a new window, the bottom of the page (page content and scroll bar control) is cut off.  If you resize the window in any way, then the window is redrawn with the bottom of the page (page content and scroll bar control) fully visible.


Expected results:

The bottom of the page should have been fully visible without having to resize the window.

Interestingly, if you right-click a link and select "Open Link in New Window", then the page is displayed correctly.  It seems that the cutoff occurs only if the page is opened in a new window via the link's "target" attribute.

Updated

a year ago
Component: Activity Streams: General → Untriaged
This is already fixed by bug 1269462.
the bug was for OS X, but the change there fixed this issue on Windows as well :)

https://hg.mozilla.org/integration/mozilla-inbound/rev/b1b49f499ae6
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
QA Whiteboard: [bugday-20160725]
Component: Untriaged → Toolbars and Customization
Resolution: --- → DUPLICATE
Duplicate of bug: 1269462
You need to log in before you can comment on or make changes to this bug.