Closed Bug 1288961 Opened 4 years ago Closed 3 years ago

[writing-mode] Wrong glyph orientation of Tangut script on vertical layout mode

Categories

(Core :: Layout: Text and Fonts, defect)

47 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla53
Tracking Status
firefox53 --- fixed

People

(Reporter: shanshandehongxing, Assigned: jfkthame)

References

Details

Attachments

(2 files)

User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

The Tangut script has introduced in Unicode last month, as the Unicode Standard, “its implementation requires technology support similar to that used for CJK”, so this script should get predictable effect in both horizontal and vertical text layouts.

I got several Tangut characters from BabelMap 9.0.0.1, then I paste them in an online editor example provides by WYMeditor integration example (https://wymeditor.github.io/wymeditor/dist/examples/01-basic.html). Then I make the whole Tangut characters display in Han based vertical layout (writing-mode: vertical-lr).


Actual results:

When the Tangut characters displaying directly within vertical layout, every glyph seems rotated 90°, but when I add “text-orientation: upright” property, they get the expected effect. See my attachment.


Expected results:

The Tangut characters should upright in a vertical line even if you are not set its orientation. If you want to get materials now, you can visit the following resource:
https://commons.wikimedia.org/wiki/Category:Tangut_script
Summary: rong glyph orientation of Tangut script on vertical layout mode (writing-mode: vertical-lr) → Wrong glyph orientation of Tangut script on vertical layout mode (writing-mode: vertical-lr)
Summary: Wrong glyph orientation of Tangut script on vertical layout mode (writing-mode: vertical-lr) → [writing-mode] Wrong glyph orientation of Tangut script on vertical layout mode
(In reply to Krasnaya Ploshchad from comment #0)
> Then I make the whole Tangut characters display in Han based vertical layout
> (writing-mode: vertical-lr).

I made a mistake when I report, I used “vertical-rl” value instead of “vertical-lr”.
The unicode support in Gecko has not yet been updated to unicode 9.0; that's bug 1281448. So at this point, it's not surprising that Tangut is not yet supported.

Regarding the default glyph orientation in particular, this will be dependent on the UTR-50 data file, as found in http://www.unicode.org/Public/vertical/. But AFAICS, UTR-50 has not yet been updated for unicode 9, so the data file we need is not yet available; the latest is still revision-15, based on unicode 8.0.
Depends on: 1281448
UTC is working on the update to UTR#50, please stay tuned. Having this report helps our work, deeply appreciated.
UTC approved UTR#50 rev 16 and UTC will publish rev 17 without any data changes since 16, so you can either take 16 data or wait for 17 a little more.
http://www.unicode.org/reports/tr50/tr50-16.html
Assignee: nobody → jfkthame
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
FWIW, I opened an issue at ICU tracker few days ago to support Vertical_Orientation property http://bugs.icu-project.org/trac/ticket/12850 so that projects already using ICU don’t have to manually track UTR#50.
Attachment #8810918 - Flags: review?(m_kato) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/fe4bc7ea5c438d942a20845c010a534971740c80
Bug 1288961 - Update UTR-50 data to version 16, for Unicode 9 support. r=m_kato
FYI, UTR#50 will be UAX#50 in Unicode 10, so we expect rev 17 should be the last revision of UTR#50. That means 1) better synchronized with the Unicode core spec and 2) the data will be part of UCD.
https://hg.mozilla.org/mozilla-central/rev/fe4bc7ea5c43
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla53
You need to log in before you can comment on or make changes to this bug.