Selecting Address book pops up web page

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Address Book & Contacts
--
critical
RESOLVED WORKSFORME
16 years ago
14 years ago

People

(Reporter: Moshe Yudkowsky, Assigned: racham)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
When I have Mozilla mail *only* running -- no other Mozilla windows open -- and
then I select address book (Tasks->Address Book), the address book pops open a
window. But I also get a new Mozilla window (!!), which attempts to go this
invalid web page:


<http://apps5.oingo.com/apps/domainpark/domainpark.cgi?s=find&dp_lp=7&cid=GOTO6262&dp_format=1.3&dp_p4pid=idealab&dp_own=Idealab&dp_cm=_b&dp_c1=000099>

If this is supposed to happen I am extremely confused. IIRC this also used to
happen in 0.9.8, but I thought it was something I'd done...

Comment 1

16 years ago
Trunk build 2002-04-08: WinMe, Linux RH 7.1, worksforme.
After starting the app with "-mail", mail opens and selecting the Address Book
icon in the bottom left opens the address book window. 

What happens in a new profile?

Marking Worksforme for now.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

16 years ago
I just tried this again with build 0.99+ (2002040706) on Mandrake Linux 8.1, 
GNOME, and I get slightly less anamolous behaviour but I still have a bug.

(1) Open Mozilla.

(2) Open the mail window (I don't enter the password, I just hit cancel, not that 
I think it makes a difference) by selecting Task -> Mail.

(3) On the mail window, hit the addressbook icon in lower left-hand corner.

(4) The Addressbook window pops open.

(5) But the Browser window then climbs up to the top of the stack, obscuring the 
address book window.

The Browser window no longer attempts to reach that wacky URL, but this is still 
unsual behaviour. There's no reason for the Browser to come to the foreground.

(I note that the original bug was written while using KDE. I doubt this makes a 
difference.)

Comment 3

16 years ago
Using Mandrake Linux 8.1 with Moz 0.9.9 build in a new profile and Gnome, we are
unable to duplicate the problem.

- There should be a way to control window focus, what are your settings? The
menu item might be called Focus Window.

- What window manager are you using?

- If you are in the browser, what happens when you select the Address Book icon
in the bottom left?
(Reporter)

Comment 4

16 years ago
I see that you aren't able to duplicate this. I am using build 2002040706, which
I loaded specifically to test bug fixes.

I am also adding a new symptom -- this same behaviour occurs if I select
Addressbook from the menu, or if I use CTRL-5 to get the addressbook.

Mandrake 8.1, GNOME 1.4.0.1 (guessing from GNOME's control panel).

YOUR QUESTION: What window manager are you using?
(I assume you meant to ask this question first!)
ANSWER: I'm using GNOME as my desktop on top of sawfish.

YOUR QUESTION: There should be a way to control window focus, what are your
settings? The menu item might be called Focus Window.

ANSWER: I assume you mean the focus for the window manager -- I've never seen
"focus" as a separate control for Mozilla. In any case, the focus is set to:

"does click to focus pass through to the window" -- YES
"focus on application windows when they first appear" -- YES
(Please note that this means I should get focus in the addressbook and I do not.)
"Dialog windows inherit the focus from their parent" -- YES
"Raise windows when they are focused" -- NO
"When does the mouse pointer affect focus" -- CLICK

This latter one being the most important. The addressbook behaviour that I'm
seeing is unexpected and doesn't occur for other programs.

YOUR QUESTION: If you are in the browser, what happens when you select the
Address Book icon in the bottom left?

ANSWER: When I select that icon, the Addressbook window pops open, and then the
original window comes to the foreground. The window no longer attempts to go to
that wacky URL, but it does come to the top.

Just now, out of curiosity, I tried to see what would happen if I selected
addressbook via Window->Addressbook or CTRL-5. In both instances, I see the
Addrsssboook window briefly outlined -- just the borders -- and then it seem to
manifest itself behind the Navigator window. I.e., this problem is triggered by
any invocation of the Addressbook.

I'd like point out that it is that visually it's hard to distinguish between a
manifestation behind the Navigator window and a quick switch. Thinking on it, I
would characterize this as almost a pop-behind window.

Note also that it only pops behind the Navigator window that's open. The window
doesn't go behind, e.g., a terminal window that's also open on the desktop.

Please note one peculiarity of my profile. I have a valid email account, etc.,
but I don't have the password stored. Also, due a superblock problem, all my
email files (in Mail/) were restored by me from lost+found. I sincerely doubt
that this has anything to do with this focus problem, especially because I had
it before I had the superblock problem.

Please let me know if you need me to do something wacky, like save .mozilla to a
new directory and see if the problem persists even with a pristine profile.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.