Closed Bug 1289032 Opened 4 years ago Closed 4 years ago

2.78 - 3.17% tart (linux64) regression on push 67186c2d647ed2807eacc51cc834ca7932d38fba (Fri Jul 22 2016)

Categories

(Core :: Graphics, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- affected

People

(Reporter: ashiue, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression, Whiteboard: [gfx-noted])

Talos has detected a Firefox performance regression from push 67186c2d647ed2807eacc51cc834ca7932d38fba. As author of one of the patches included in that push, we need your help to address this regression.

Summary of tests that regressed:

  tart summary linux64 opt e10s - 3.17% worse

You can find links to graphs and comparsion views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=2016

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
I did some retriggers for this alert, here is the zooming better view:
https://treeherder.mozilla.org/perf.html#/graphs?series=%5Bautoland,34025020e068f8204ca2174832747ef815aa3b65,1,1%5D&zoom=1469077769462.8098,1469166784743.8018,5.800000000000001,6.285074626865672

This issue might be caused by push 67186c2d647ed2807eacc51cc834ca7932d38fba.
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=cd5af43f84b11096643c2418d3af263cf92c7bdd&tochange=67186c2d647ed2807eacc51cc834ca7932d38fba

Hi Benoit, as you are the patch author, can you take a look at this and determine what is the root cause? Thanks!
Blocks: 1280481, 1287066
Flags: needinfo?(bgirard)
Thanks for reporting this alert.

Is the region restricted to linux64 tart? If I had to guess I'd say the compiler decided to stop inline SetVisibleRegion because it's above the threshold. TART is pretty much a microbenchmark and is be very sensitive to this change.

TART is doing this job effectively at detecting that something increased rendering time, which given the patch it's expected given that we're adding a branch in a hot part of the code and might of lost inlining. We're looking at a fraction of a millisecond lost due to this.

I think we should leave it. Also this code might chance given bug 1288464 and I'll keep this in mind and I'll remove the branch from SetVisibleRegion if the outcome of bug 1288464 allows it.
Flags: needinfo?(bgirard)
here is a compare view of your push vs the previous:
https://treeherder.mozilla.org/perf.html#/compare?originalProject=autoland&originalRevision=cd5af43f84b1&newProject=autoland&newRevision=67186c2d647e&framework=1

it looks like it is just the linux64 tart regression, the other possibilities are within the normal range of data points.  Please resolve this as wontfix if there is no actionable work here!
Whiteboard: [gfx-noted]
Benoit, are we good to wontfix this?
Flags: needinfo?(bgirard)
Yes. I think it's the right call here.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bgirard)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.