Closed Bug 1289116 Opened 3 years ago Closed 14 days ago

Page with long <fieldset> does not print properly

Categories

(Core :: Printing: Output, defect)

47 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 471015
Tracking Status
firefox47 --- affected
firefox48 --- affected
firefox49 --- affected
firefox-esr45 --- affected
firefox50 --- affected

People

(Reporter: mlipscke, Assigned: mats)

References

()

Details

(Keywords: productwanted)

Attachments

(4 files)

165.85 KB, application/pdf
Details
626.50 KB, application/pdf
Details
399.55 KB, application/x-zip-compressed
Details
8.05 KB, application/x-zip-compressed
Details
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/51.0.2704.103 Safari/537.36

Steps to reproduce:

I added 220 articles to my wishlist. Then i wanted to print my wishlist. 


Actual results:

The first page only contains the title (wishlist), the second page only contains 10 of 220 articles, the third page is empty. So there were only 10 of 220 articles.


Expected results:

Firefox should print the whole page like every other browser. This only happens with firefox. Opera, Chrome and even Internet Explorer print the site properly.
OS: Unspecified → All
Hardware: Unspecified → All
Could you copy the link to your wishlist, so we could test.
Component: Untriaged → Printing: Output
Flags: needinfo?(mlipscke)
Product: Firefox → Core
I cant, because this is stored in a cookie.

Here is the link to the wishlist with print button: http://bootsport.sprenger.de/merchant/checkout/print/

Here is the Print-Preview: http://bootsport.sprenger.de/merchant/print/index/

just add more then 10 articles to see the bug.
Attached file reduced html
So, this seems to be duplication of Bug 471015
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: productwanted
See Also: → 471015
Flags: needinfo?(mlipscke)

The attached testcase works in my local build.

Assignee: nobody → mats
Status: NEW → RESOLVED
Closed: 14 days ago
Resolution: --- → DUPLICATE
See Also: 471015
Summary: Page does not print properly → Page with long <fieldset> does not print properly
Duplicate of bug: 471015
You need to log in before you can comment on or make changes to this bug.