Artifacts along the border of the window

VERIFIED FIXED in Firefox 50

Status

()

P2
normal
VERIFIED FIXED
2 years ago
a year ago

People

(Reporter: dcamp, Assigned: jfkthame, NeedInfo)

Tracking

(Depends on: 2 bugs, {regression})

50 Branch
mozilla51
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox50 verified, firefox51 verified)

Details

(Whiteboard: tpi:+)

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8774357 [details]
BorderBug.PNG

I'm getting a border around my windows.  Usually white, but sometimes artifacts show up in the border.

Surface Book i7 on the latest insider ring anniversary preview builds.  They seem to appear when I attach to an external (standard-def) monitor, and disappear when I'm back on the laptop display.
(Reporter)

Comment 1

2 years ago
In the off chance it's helpful, the border seems to be about twice as large when maximized.
With bug 1249500 gone with the update, something else with external monitors :)

Jonathan, Markus, could this be related to a fix in bug 1154125?

Dave, do you know if this worked on earlier versions of Firefox, while using the latest preview builds?
Flags: needinfo?(jfkthame)
Flags: needinfo?(dcamp)
(Assignee)

Comment 3

2 years ago
I think this is a regression from bug 1270954 (Dave, maybe you can confirm that by testing nightly builds from before/after it landed?).

AFAICT, this does -not- occur if you turn on the title bar; it only occurs when we're doing the "tabs in titlebar" thing. Could you try enabling the title bar in Customize, and confirm whether that resolves what you're seeing? Thanks.

I saw problems like this when I first started testing the patch in bug 1270954, and so I held back from getting that reviewed/landed for a while. Then the problem seemed to go away, and I thought that meant it had been an Insider-build issue that got fixed. But now I'm wondering if somehow I didn't test correctly, and the problem has been there all along.
Blocks: 1270954
Flags: needinfo?(jfkthame)
Keywords: regression
(Reporter)

Comment 4

2 years ago
Can confirm that it goes away if you turn on the title bar.
Flags: needinfo?(dcamp)
Component: Graphics → Widget: Win32
Version: unspecified → 50 Branch

Updated

2 years ago
Priority: -- → P2
Whiteboard: tpi:+
(Assignee)

Comment 6

2 years ago
Created attachment 8788624 [details] [diff] [review]
Apply the appropriate scaling to window edges when processing WM_NCCALCSIZE for a window on a secondary screen with non-system DPI

The problem here occurs when you have a hi-dpi (e.g. 200% scaling) primary monitor, and a browser window on a lo-dpi secondary display with 100% or 125% scaling. (At 150% or more, I'm not seeing it; it probably disappears somewhere in rounding to whole pixels.) Anyhow, I think this patch resolves the bug, by adjusting the handling of WM_NCCALCSIZE to account for scaling of the window edges. :dcamp, could you test with the tryserver build (above) and confirm whether it fixes the issue for you?
Attachment #8788624 - Flags: review?(VYV03354)
(Assignee)

Updated

2 years ago
Flags: needinfo?(dcamp)
(Assignee)

Comment 7

2 years ago
BTW, the patch here improves behavior even prior to Win10 Anniv Update and the introduction of non-client area scaling, in that it maintains the window's innerWidth better (to within a pixel or so, due to possible rounding effects) when a window is moved between displays of different resolutions.

So it will reduce the existing tendency for a page to suffer unexpected layout changes when moving the window because of a resolution switch causing a change to the available CSS-px width.
Attachment #8788624 - Flags: review?(VYV03354) → review+
(Assignee)

Comment 8

2 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/c3771535a47ebb8260de3362188c83790831867e
Bug 1289143 - Apply the appropriate scaling to window edges when processing WM_NCCALCSIZE for a window on a secondary screen with non-system DPI. r=emk
(Assignee)

Comment 9

2 years ago
Comment on attachment 8788624 [details] [diff] [review]
Apply the appropriate scaling to window edges when processing WM_NCCALCSIZE for a window on a secondary screen with non-system DPI

Approval Request Comment
[Feature/regressing bug #]: 1270954

[User impact if declined]: possibility of small visual glitches (see screenshot) along the edges of windows on a secondary monitor

[Describe test coverage new/current, TreeHerder]: tested manually on both Win10 and Win8.1 with mixed resolution configurations

[Risks and why]: low risk - Windows-only patch, has no effect unless displays with varying resolution are present

[String/UUID change made/needed]: none
Attachment #8788624 - Flags: approval-mozilla-aurora?
(Assignee)

Updated

2 years ago
Assignee: nobody → jfkthame

Comment 10

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/c3771535a47e
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-firefox51: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla51

Updated

2 years ago
status-firefox50: --- → affected
Comment on attachment 8788624 [details] [diff] [review]
Apply the appropriate scaling to window edges when processing WM_NCCALCSIZE for a window on a secondary screen with non-system DPI

Recent regression, Aurora50+
Attachment #8788624 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
(Assignee)

Comment 12

2 years ago
https://hg.mozilla.org/releases/mozilla-aurora/rev/7a8b1ac451d9
status-firefox50: affected → fixed
Blocks: 1302168
Flags: qe-verify+
Verified this issue as fixed on Windows 8.1 x64 and Windows 10 x64 with 2 monitors having mixed resolutions.

Testing performed using:
- Firefox 50.0b9, build ID 20161020152750;
- Latest 51.0a2 Aurora, build ID 20161024004016.
Status: RESOLVED → VERIFIED
status-firefox50: fixed → verified
status-firefox51: fixed → verified
Flags: qe-verify+
QA Contact: cornel.ionce
No longer blocks: 1361758
Depends on: 1361758
You need to log in before you can comment on or make changes to this bug.