Closed Bug 1289203 Opened 4 years ago Closed 3 years ago

Inspector is slowing down a test page with ~300 elements that have inline styles being mutated constantly

Categories

(DevTools :: Inspector, defect, P2)

46 Branch
defect

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: bgrins, Unassigned)

References

(Blocks 2 open bugs, )

Details

I'm guessing this is because of mutation flashing on the frontend since the jank is worst when the inspector is opened as opposed to any other tool, but it needs some profiling.

Here's the test page: https://m8y.org/hw/hats_js_anim.xhtml
Inspector bug triage, filter on CLIMBING SHOES.

Not a regression but makes the inspector & firefox unusable -> P2.
Priority: -- → P2
I could not reproduce on my MBP (can test on a lower end machine tomorrow). Is this still an issue?
Flags: needinfo?(bgrinstead)
(In reply to :Harald Kirschner :digitarald from comment #2)
> I could not reproduce on my MBP (can test on a lower end machine tomorrow).
> Is this still an issue?

It does seem better to me now. This could well be an e10s-related fix - IIRC the issue was the animated icons on the page would jank once the inspector was opened. Feel free to close this if you can't reproduce when testing on a lower end machine.
Flags: needinfo?(bgrinstead) → needinfo?(hkirschner)
Checking on my i5 3.3ghz linux machine w/ radeon 4670 which I'm pretty sure was the machine I used last time around and seems perfectly usable now.  Page elements interact just fine, rest of UI does not lock up.  Does seem to be fixed.
Oh, and CPU usage *is* at 166% but whatever.  So long as it doesn't lock everything up.  Also I'd swear I tried it w/ e10s way back when.  Maybe inspector was moved out of main process or something.
(In reply to nemo from comment #5)
> Oh, and CPU usage *is* at 166% but whatever.  So long as it doesn't lock
> everything up.  Also I'd swear I tried it w/ e10s way back when.  Maybe
> inspector was moved out of main process or something.

What does CPU usage drop to when the Inspector isn't opened?
50% (I'm adding up all the usual suspects BTW, firefox, web content, Xorg)

But, yeah, not surprising that updating all those attributes slows things down a bit.  I'm just glad it isn't locking up the hamburger menu and tabs anymore.
I assume there's still some inspector specific optimizations that could be made here - I can't think of anything in particular we've done anything to significantly improve this case from the devtools end (although it's possible). Most likely we are just benefiting from e10s and quantum work, but I'm still inclined to close this bug since it doesn't reproduce, and leave bug 1171482 open for the optimization.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(hkirschner)
Resolution: --- → WORKSFORME
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.