PlatformHandleHelper's implicit conversion to PlatformHandleType fails on MSVC

RESOLVED DUPLICATE of bug 1264566

Status

()

RESOLVED DUPLICATE of bug 1264566
2 years ago
2 years ago

People

(Reporter: bryce, Assigned: bryce)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
The code:
>>  FileDescriptor::PlatformHandleHelper::operator PlatformHandleType

in ipc/glue/FileDescriptor.cpp, is failing to build on latest version of msvc. This looks to be due to the scoping rules for inner and outer types being treated differently than on other compilers. This may have changed in later versions of MSVC, as I haven't seen it previously.

As such, the PlatformHandleType needs to be explicitly namespaced:
>> FileDescriptor::PlatformHandleHelper::operator FileDescriptor::PlatformHandleType
(Assignee)

Comment 1

2 years ago
Created attachment 8774520 [details]
Bug 1289235 - Fix failing msvc compilation for PlatformHandleHelper implicit conversion.

MSVC requires explict namespacing on for the implicit conversion, which is
added in this changeset.

Review commit: https://reviewboard.mozilla.org/r/66956/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/66956/
Attachment #8774520 - Flags: review?(wmccloskey)
Why is the patch private?
(Assignee)

Comment 3

2 years ago
Push to review being flakey, attempting to get it to play nice now.
Assignee: nobody → bvandyk
(Assignee)

Comment 4

2 years ago
Comment on attachment 8774520 [details]
Bug 1289235 - Fix failing msvc compilation for PlatformHandleHelper implicit conversion.

MSVC requires explict namespacing on for the implicit conversion, which is
added in this changeset.

Review commit: https://reviewboard.mozilla.org/r/66956/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/66956/
this is fixed in a followup.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1264566
You need to log in before you can comment on or make changes to this bug.