Closed Bug 1289270 Opened 4 years ago Closed 4 years ago

7.94% tp5o responsiveness (windowsxp) regression on push 476d94850f6aaea6912cf75afff06e046013797d (Wed Jul 20 2016)

Categories

(Core :: JavaScript: GC, defect)

50 Branch
defect
Not set

Tracking

()

RESOLVED WONTFIX
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- affected

People

(Reporter: ashiue, Unassigned)

References

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push 476d94850f6aaea6912cf75afff06e046013797d. As author of one of the patches included in that push, we need your help to address this regression.

Summary of tests that regressed:

  tp5o responsiveness windowsxp opt e10s - 7.94% worse


You can find links to graphs and comparsion views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=2026

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
The TP5 tests are not synced against GC, so any change to our slice timing winds up appearing as a regression half the time. WinXP seems particularly susceptible to this, possibly because of the software CV. The patch doesn't add any new code, but might affect our wakeup times enough to perturb when the GC slices happen. Given that other platforms do not show the same regression and that the WinXP numbers are already back to where they were before, I don't think this is a real bug. There is certainly nothing actionable here.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(terrence)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.