Closed Bug 1289537 Opened 7 years ago Closed 6 years ago

The new eyedropper cannot move outside of document

Categories

(DevTools :: General, defect, P3)

defect

Tracking

(firefox50 affected, firefox51 affected)

RESOLVED WONTFIX
Tracking Status
firefox50 --- affected
firefox51 --- affected

People

(Reporter: magicp.jp, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

1. Start Nightly
2. Go to any sites (e.g. about:home)
3. Open DevTools > Inspector
4. Run new eyedropper and move to nav-bar


Actual results:

The new eyedropper cannot move outside of document


Expected results:

The new eyedropper can move inside of the browser window.
Regression range:
https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=e0bc88708ffed39aaab1fbc0ac461d93561195de&tochange=a7a882d122e36defe6c2a102a28ae7dfc16311c5
Blocks: 1262439
Has Regression Range: --- → yes
Has STR: --- → yes
Component: Untriaged → Developer Tools
OS: Unspecified → All
Hardware: Unspecified → All
FWIW, this limitation is known and was discussed in the original bug : https://bugzilla.mozilla.org/show_bug.cgi?id=1262439#c2
This was indeed a known limitation when we started to work on the new implementation of the eyedropper.
Because we're not using XUL anymore, we can't use floating XUL panels (which can extend out of the bounds of the browser) and instead the eyedropper is injected as a devtools highlighter [1] into the page, therefore constraining it to the page's bounds.

I don't think this is a regression worth fixing, and we wouldn't be able to fix it with the new implementation. So marking as WONTFIX based on this.

[1] https://wiki.mozilla.org/DevTools/Highlighter
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.