Firefox addons make it start slow

RESOLVED WONTFIX

Status

()

Firefox
Untriaged
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: andreip, Unassigned)

Tracking

50 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: wontfix?)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160726080520

Steps to reproduce:

Install 8 firefox addons
Start Firefox


Actual results:

It takes 9 seconds to start


Expected results:

It should start instantly (under 1s) just like a new install or at least it should start in 2s like the same profile but with the addons disabled.
(Reporter)

Comment 1

2 years ago
Also if I start another instance of Firefox with the same profile and I run 

firefox -P "default" -new-window

Then the second instance appears instantly.

Can we have some sort of a headless mode where a Firefox process starts with no visible windows at system startup and when I click the Firefox icon it just spawns a new Firefox Window that connects to the existing process with the existing profile?

The addons that I have installed are irrelevant. I tried to find the one that makes it slow but all of them make it a little bit slower. Firefox's most powerful feature is it's customization (so in part the addons that are available). If more addons make it slow, people will use less addons.

Chrommium starts instantly regardless of the number of addons installed.

Comment 2

2 years ago
If you install additional software using additional resources, it affects performance.
What is this bug report about?
Currently it says "Firefox addons make it start slow" which is a fact and not a bug in itself.
Hence proposing to close this ticket as INVALID.
Flags: needinfo?(andrei)
(Reporter)

Comment 3

2 years ago
It's not a bug, it's a feature request. Can I mark it somehow as a feature request?

I think this is a pretty big issue for a lot of users. If they put a handful of extensions in Google Chrome and they start the browser, it starts instantly but if they do the same with Firefox it boots slow.

Firefox with a few addons starts almost as slow as my entire Fedora operating system with Gnome Shell and more GS extensions that FF extensions.

I installed the MinimizeToTray revived extension and start a Firefox instance when my OS boots and hide it in system tray. When I open a new Firefox windows it starts instantly. Basically I replicated with an addon and a few hacks what Chromium/Chrome have and I wish that this would be a builtin feature of Firefox. I think a lot of users are bothered by this even if they don't explicitly say this.
Flags: needinfo?(andrei)

Comment 4

2 years ago
Which feature do you request in this ticket? 
I fail to see any description of non-existing functionality in this ticket...
Flags: needinfo?(andrei)
(Reporter)

Comment 5

2 years ago
I think Firefox should start a new browser process without a visible window when the operating system starts. When I click on a Firefox desktop icon then, since there is already a background process opened, a Firefox window should pop up instantly regardless of the number of addons I have installed.

I have been able to replicate this feature by using the FireTray addon https://addons.mozilla.org/en-US/firefox/addon/firetray/

The problem with this approach is that I think such a feature should be builtin. A browser should seem to start instantly (that's how Chrommium is doing it also). I am a power user and I know how to install this addon, configure it and set Firefox as a startup process. Most users do no know how to do this. They install Chrome and Firefox, put a few addons on both and they see that Chrome starts instantly while Firefox takes a lot of seconds.

Also the addon is discontinued and uses APIs that will be removed soon. I don't think I should have an addon that makes Firefox seem to start instantly, it should be a builtin feature and not an addon.
(Reporter)

Updated

2 years ago
Flags: needinfo?(andrei)

Comment 6

2 years ago
(In reply to andrei from comment #5)
> The problem with this approach is that I think such a feature should be
> builtin.

So you're only requesting the *feeling* that Firefox starts fast, by preloading stuff into the RAM?
I strongly disagree. Having this not only built-in but also enabled by default, it occupies a lot of resources on machines for no reason, especially if I imagine other software to feel also 'important' enough to fight for blocking most of my machine's RAM. 
The result would be that Firefox slows down my *entire* system even if it's not visibly running. Which is way worse than the perception problem you're describing in this task.

Proposing to close this ticket as WONTFIX / WORKSFORME: Solution (via add-on) exists and it's an implementation detail whether it's built-in or not. (And if you disagree that it's an implementation detail you likely argument that *any* add-ons are too hard to install for average users.)
The argumentation that "most users do no know how to do this" remains the same, no matter if it's about installing an add-on or changing some hidden configuration setting, and that argumentation can be applied to nearly every setting out there.

Comment 7

2 years ago
Currently there are no plans to provide this idea in the native application, as your idea likely would only be useful for a smaller amount of users. However it could always become an extension or add-on which would be provided by third party developers, but not by the Mozilla developers themselves. Hence setting WONTFIX for the native application.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix?
(Reporter)

Comment 8

2 years ago
Ok. I hope the discontinued addon will work for more time in the future.
You need to log in before you can comment on or make changes to this bug.