Need 16x16 icons for components

VERIFIED FIXED

Status

SeaMonkey
Themes
VERIFIED FIXED
16 years ago
10 years ago

People

(Reporter: jag (Peter Annema), Assigned: marlon bishop)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2])

Attachments

(5 attachments, 5 obsolete attachments)

(Reporter)

Description

16 years ago
For bug 128959, bug 128960, bug 128964.
(Reporter)

Updated

16 years ago
Blocks: 128959, 128960, 128964

Comment 1

16 years ago
no art until you get mozilla.org to fix licensing.

talk to mitchell :-)

Comment 2

16 years ago
adding self to cc list

Updated

16 years ago
Blocks: 135455
*** Bug 136415 has been marked as a duplicate of this bug. ***

Comment 4

16 years ago
*** Bug 136772 has been marked as a duplicate of this bug. ***

Comment 5

16 years ago
I'm not sure what timeless is talking about but we do need to replace the icons
in the Window menu with ones that aren't stretched before RC1 or we need to back
out that change (bug 128959). This will certainly be one of the most duplicated
bugs filed on RC1 if it's allowed out the door. I intend to not allow it out the
door with this half-implemented change to the Window menu. RC1 will be ready to
go in days and not weeks so if we plan on keeping this feature in for RC1 then
we need new icons.
Blocks: 134771

Comment 6

16 years ago
Icons in window menu are horrible. Everyone will notice. 

Remove them or fix them. This bug should have a higher priority.
*** Bug 137245 has been marked as a duplicate of this bug. ***

Comment 8

16 years ago
Comment 5 : '..but we do need to replace the icons in the Window menu with ones
that aren't stretched before RC1 or we need to back out that change (bug 128959).'

Sounds like a blocker to me.
Keywords: mozilla1.0

Comment 9

16 years ago
Created attachment 79279 [details] [diff] [review]
Set of 16x16-icons for modern

Here are icons for modern: navigator, mail, composer and addressbook. Based on
the original ones, size and some cackground transparencies corrected.

Comment 10

16 years ago
Created attachment 79280 [details]
same icons in the same zip file

zip file is no patch, obviously. Sorry for the spam.
Attachment #79279 - Attachment is obsolete: true

Comment 11

16 years ago
Created attachment 79282 [details]
Screenshot modern with new icons

Comment 12

16 years ago
Created attachment 79286 [details]
zip-file containing 4 16x16-icons for classic

Here is a set of 16x16-icons for classic: navigator, mail, composer and
addressbook. Again, based on the original ones, size changed to 16x16.

Comment 13

16 years ago
Created attachment 79287 [details]
And finally a screenshot for classic with the "new" icons.

Comment 14

16 years ago
marlon, will you please take a look at the icons? 
Chatzilla probably needs some more changes.
Keywords: patch, review

Comment 15

16 years ago
I tried to add an icon for chatzilla, here is my problem:

in chatzillaOverlay.xul, I added 
        class="menuitem-iconic icon-chatzilla16 menu-iconic"
to the <menuitem> in <menupopup id="windowPopup">.

In chatzilla.css, I added a class
.icon-chatzilla16 {
  list-style-image: url("chrome://chatzilla/skin/images/chatzilla-16.gif"); }

However, the icon does not show up, I presume because chatzilla.css is only
loaded when chatzilla is actually invoked.
The taskbar-icon for chatzilla is defined directly in chatzillaOverlay.xul
(like this: image="chrome://chatzilla/skin/images/chatzilla-16.gif").

Is there a possibility to add the information about the icon directly in
chatzillaOverlay.xul, or some other place that is read at startup, and if yes,
where?

Comment 16

16 years ago
Created attachment 79292 [details]
16x16-icon for chatzilla

Not yet build in, but if needed in the future, it is here.

Comment 17

16 years ago
Andreas:
To specify it directly in chatzillaOverlay.xul would/could break alternative
skins for chatzilla.
The right way to do that is to add a chatzillaOverlay.css file and link it from
chatzillaOverlay.xul

Look into calendar for a good example!
(Assignee)

Comment 18

16 years ago
those icons are good, thanks.. the only thing i would suggest based on that
screenshot is to middle align the icon with the menu text.

Comment 19

16 years ago
Created attachment 79336 [details]
zip-file containing 4 16x16-icons for modern, revised

icons for navigator, mail, composer, addressbook for modern. Centered
vertically with the menu text.
Attachment #79280 - Attachment is obsolete: true
Attachment #79282 - Attachment is obsolete: true

Comment 20

16 years ago
Created attachment 79338 [details]
zip-file containing 4 16x16-icons for classic

Same as above, revised for vertical alignment
Attachment #79286 - Attachment is obsolete: true
Attachment #79287 - Attachment is obsolete: true

Comment 21

16 years ago
Created attachment 79339 [details]
Screenshot modern

Comment 22

16 years ago
Created attachment 79343 [details]
Finally, screenshot for classic, revised icons
(Assignee)

Comment 23

16 years ago
looks great, thanks again

Comment 24

16 years ago
adt1.0.0+ (on ADT's behalf) for checkin into the 1.0 branch. Pls check this in
to the branch today. After it is checked in, pls add fixed1.0.0. Once QA has
verified it on the branch, then add verified1.0.0.
Keywords: adt1.0.0+
Whiteboard: [adt2]

Updated

16 years ago
Attachment #79338 - Attachment mime type: image/gif → application/zip

Updated

16 years ago
Attachment #79336 - Attachment mime type: application/octet-stream → application/zip

Comment 25

16 years ago
marlon, can you provide for checkin into the branch. Who is going to review this
change?

Comment 26

16 years ago
are you sure attachment 79336 [details] contains modern icons?

Comment 27

16 years ago
Pretty sure. Just checked again by downloading from bugzilla: attachment 79336 [details]
are modern, attachment 79338 [details] are classic icons.

Comment 28

16 years ago
> Pretty sure. Just checked again by downloading from bugzilla: attachment 79336 [details]
> are modern, attachment 79338 [details] are classic icons.

That's what I get.
(Reporter)

Comment 29

16 years ago
Assuming r=marlon, sr=jag.

Comment 30

16 years ago
<jag says...> checked in on the branch and trunk.  marking accordingly.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Keywords: fixed1.0.0
Resolution: --- → FIXED

Comment 31

16 years ago
verified on linux and windows 98 mozilla branch build (2002-04-25-08-1.0.0)
and commercial trunk (2002-04-25-12-TRUNK)
Status: RESOLVED → VERIFIED
Keywords: verified1.0.0
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.