[OS X] Firefox Nightly 50.0a1 shows no "Bookmarks Menu" contents when no windows opened.

VERIFIED FIXED in Firefox 49

Status

()

defect
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: suishouen, Assigned: dao)

Tracking

({regression})

50 Branch
Firefox 51
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox47 unaffected, firefox48 unaffected, firefox49 verified, firefox50 verified, firefox51 verified)

Details

Attachments

(2 attachments)

Posted image Screen Shot.png
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:50.0) Gecko/20100101 Firefox/50.0
Build ID: 20160726080520

Steps to reproduce:

Close all windows or all tabs.


Actual results:

When I click Bookmarks menu, Bookmarks menu shows no "Bookmarks Menu" contents.


Expected results:

"Bookmarks Menu" contents should be shown.
Regression range:
  https://hg.mozilla.org/integration/fx-team/pushloghtml?fromchange=70b3e6ac383941005652196f432d9134dea468a7&tochange=f98e3add979e3b2eba6461fdaed2cfc80961ff6f

apparently a regression from bug 1248268.

When I open the "bookmarks" menu without any window, the following error is thrown:

> TypeError: placesContextMenu is null
> browser-places.js:1429:5

https://dxr.mozilla.org/mozilla-central/rev/ceb63dec9267e9bb62f5e5e1f4c9d32d3ac1fbac/browser/base/content/browser-places.js#1429
>     placesContextMenu.addEventListener("popupshowing", onPlacesContextMenuShowing);
Blocks: 1248268
Status: UNCONFIRMED → NEW
Component: Untriaged → Bookmarks & History
Ever confirmed: true
Keywords: regression
Dao, can you look at this since the regressing bug was yours?
Flags: needinfo?(dao+bmo)
Assignee: nobody → dao+bmo
Flags: needinfo?(dao+bmo)
Posted patch patchSplinter Review
Attachment #8779701 - Flags: review?(mdeboer)
Comment on attachment 8779701 [details] [diff] [review]
patch

Review of attachment 8779701 [details] [diff] [review]:
-----------------------------------------------------------------

Thanks!
Attachment #8779701 - Flags: review?(mdeboer) → review+
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/7db46aeeaf03
Account for placesContext not existing in non-browser windows on Mac. r=mdeboer
https://hg.mozilla.org/mozilla-central/rev/7db46aeeaf03
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Can you request uplift? Looks like a regression from 49 and we could still uplift this for beta 4.
Flags: needinfo?(dao+bmo)
Comment on attachment 8779701 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: bug 1248268
[User impact if declined]: see comment 0
[Describe test coverage new/current, TreeHerder]: n/a
[Risks and why]: just a null check, super-low risk
[String/UUID change made/needed]: none
Flags: needinfo?(dao+bmo)
Attachment #8779701 - Flags: approval-mozilla-beta?
Attachment #8779701 - Flags: approval-mozilla-aurora?
Comment on attachment 8779701 [details] [diff] [review]
patch

Fix for bookmark regression in 49.  Please uplift to aurora and beta.
Attachment #8779701 - Flags: approval-mozilla-beta?
Attachment #8779701 - Flags: approval-mozilla-beta+
Attachment #8779701 - Flags: approval-mozilla-aurora?
Attachment #8779701 - Flags: approval-mozilla-aurora+
Flags: qe-verify+
I have reproduced this bug with Firefox nightly 50.0a1(build id:20160726080520)on
windows 7(64 bit)

I have verified this bug fixed with Firefox nightly 51.0a1(build id:20160822064441)
User Agent:Mozilla/5.0 (Windows NT 6.1; WOW64; rv:51.0) Gecko/20100101 Firefox/51.0

[bugday-20160824]
Thanks!
Status: RESOLVED → VERIFIED
Verified fixed on latest Nightly 51.0a1 (buildID: 20160828030602), latest Aurora 50.0a2 (buildID: 20160828004009) and Firefox 49 Beta 7 (buildID: 20160825132718).
You need to log in before you can comment on or make changes to this bug.