Ergonomy: placement of 'delete' button for threaded messages

RESOLVED DUPLICATE of bug 844475

Status

Thunderbird
Message Reader UI
RESOLVED DUPLICATE of bug 844475
a year ago
a year ago

People

(Reporter: Sciss, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

a year ago
Created attachment 8775060 [details]
Screenshot from 2016-07-27 10:23:12.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:45.0) Gecko/20100101 Firefox/45.0
Build ID: 20160607223741

Steps to reproduce:

When receiving new messages, some are individual and some are threaded and by default collapsed. When skipping through the message list, I often want to delete messages one by one. This works for individual messages as the button positions (...Archive, Junk, Delete, More) remain consistent. However when entering a collapsed threaded message, the two buttons (Archive, Delete) are assigned different screen positions.T


Actual results:

The result is that one usually accidentally clicks 'Archive' on a threaded message when one actually wants to click 'Delete' because 'Archive' has obtained the screen position that 'Delete' has for individual messages.


Expected results:

It would improve ergonomy and predictability of UI a lot if the buttons 'Archive' and 'Delete' for a selected threaded message were aligned with these two buttons in individual message view.
(Reporter)

Comment 1

a year ago
Created attachment 8775061 [details]
Screenshot from 2016-07-27 10:23:20.png
(Reporter)

Comment 2

a year ago
Created attachment 8775063 [details]
suggestion.png
perhaps we should confirm bug 844475.
There is also bug 1066738
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 844475
You need to log in before you can comment on or make changes to this bug.