Closed Bug 12897 Opened 21 years ago Closed 20 years ago

Indeterminate state after hitting "STOP" button

Categories

(Core :: DOM: Navigation, defect, P3)

x86
Windows NT
defect

Tracking

()

VERIFIED WORKSFORME

People

(Reporter: mats, Assigned: radha)

References

()

Details

To repeat:
1. Start apprunner
2. Select menu item "Debug" - "Viewer Demos" - "#8 Form"
3. Click "My Netscape" but immediately hit the "STOP" button
4. (still at test8.html) resize window

What happened:
The area occupied by the (raptor) images becomes white

Expected:
Hitting STOP before the new page is loaded should IMO either:
1. stay at current page, with no damages whatsoever
2. land on the new page with as much content displayed as possible
   followed by a message indicating that page loading was interrupted.

Tested on:
Bug occurs in nightly build 1999-08-31-09-M10 on both Windows 98 and NT.
Bug also occurs in M7, M8 and several other August builds on Windows 98.
local file loading is not working on a 10/27 build, so I can't verify if this is
still a problem
Now the stop button doesn't seem to be working with 10/28 builds, so this can't
be regressed.
I'm tempted to move this to the "History" component, but the Stop button isn't
working right now.  If this still exists when "Stop" is fixed, it probably
should go there, since it seems to me like a webshell thing...
Assignee: don → radha
Component: Browser-General → History
Moving to "History" component since it should probably be considered in the
webshell redesign.
Updating QA Contact.
Status: NEW → ASSIGNED
Target Milestone: M15
Works for me when I do the following:

1. Launch 2000-01-04-08 Linux build.
2. Load test8.html page from my 1999-12-28-08 Linux build directory.
3. Click any link on that page or click the "Home" button (which goes to
my.netscape.com), hit the stop button, and resize the window.

Note: I can't reproduce this exactly because I don't use Windows and can't find
a my.netscape.com link on the page in question, but given the age of this bug
report might it not be useful for the original reporter to check it with a
recent build?
Target Milestone: M15 → M17
I'm resolving this bug as WFM. I checked with the 2000042512 builds and i don't believe it to be a problem anymore in light of 
the new webshell and SH changes.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → WORKSFORME
marking VERIFIED
Status: RESOLVED → VERIFIED
Component: History: Session → Document Navigation
QA Contact: claudius → docshell
You need to log in before you can comment on or make changes to this bug.