If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Regression] Closing all tabs causes Firefox to stop loading webpages in the default tab

VERIFIED FIXED

Status

()

Firefox for iOS
General
--
major
VERIFIED FIXED
a year ago
a year ago

People

(Reporter: csuciu, Assigned: tlacroix)

Tracking

({regression})

unspecified
Other
iOS
regression

Firefox Tracking Flags

(fxios5.1+, fxios-v5.1 fixed, fxios-v6.0 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
master 5e2ef3fb
iPad Air 2 (9.3.2) 

1. Open Firefox and visit a webpage in the default tab => the can be visited 
2. Close the visited page by tapping on the [X] button from the tabs bar => the about:home page will be displayed in the default tab 
3. Open a few new tabs using the New Tab [+] button from the top toolbar
4. Go to tabs tray, open the Menu and tap on 'Close All Tabs' => the about:home page will be displayed in the default tab 
5. Try to visit any webpage in the default tab

Expected: Webpages can be visited

Actual: No webpage will load in the default tab after following the steps from above. 

Note: I wasn't able to reproduce this issue on phones
(Reporter)

Comment 1

a year ago
https://www.youtube.com/watch?v=ZylUrhWQ55Q
Severity: normal → major
Keywords: regression
(Assignee)

Updated

a year ago
Assignee: nobody → tlacroix
(Assignee)

Comment 2

a year ago
Created attachment 8775158 [details] [review]
https://github.com/mozilla/firefox-ios/pull/2020
Attachment #8775158 - Flags: review?(sleroux)
Blocks: 1289768
Comment on attachment 8775158 [details] [review]
https://github.com/mozilla/firefox-ios/pull/2020

I think this patch is on the wrong bug?
Flags: needinfo?(tlacroix)
(Assignee)

Comment 4

a year ago
This patch fixes a few bugs, one of which is this one and 1289768 too. When you open tabs too quickly there's a possibility of a "floating" HomePanelViewController (by that I mean we add a HomePanelViewController, set homePanelViewController to nil but dont remove it, so there becomes 2 HomePanelViewControllers when a new tab is opened) this causes the browser to become unusable.
Flags: needinfo?(tlacroix)
(Assignee)

Comment 5

a year ago
When the tab tray button is pressed in this video https://youtu.be/ZylUrhWQ55Q?t=15s you can see the "floating" HomePanelViewController during the animation :)
master ab314a630e04d5fb0e3b9d66c5334b0e026c8594

The bug was flagged as affecting 5.1 but the build this was tested on was master. Is this incorrect?
Status: NEW → RESOLVED
Last Resolved: a year ago
status-fxios-v6.0: --- → fixed
Flags: needinfo?(catalin.suciu)
Resolution: --- → FIXED
Attachment #8775158 - Flags: review?(sleroux) → review+
(Reporter)

Comment 7

a year ago
> The bug was flagged as affecting 5.1 but the build this was tested on was
> master. Is this incorrect?

Yes!
Flags: needinfo?(catalin.suciu)
status-fxios-v5.1: affected → ---
tracking-fxios: ? → 6.0+
Looks like this bug is also affecting another which is targeting 5.1:

https://bugzilla.mozilla.org/show_bug.cgi?id=1289768

Marking as uplift to resolve the other bug.
tracking-fxios: 6.0+ → 5.1+
Whiteboard: [needsuplift]
v5.x 7d90f3e
status-fxios-v5.1: --- → fixed
Whiteboard: [needsuplift]
Tested on master 3f103883 on iPad Air 2.

Webpages can be visited and are correctly loaded.
Verifying as fix on master aae3fdc32.
Status: RESOLVED → VERIFIED
status-fxios-v6.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.