Dismissed "Trending" Highlights items reappear after the browser is restarted

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
3 years ago
9 months ago

People

(Reporter: CosminMCG, Unassigned)

Tracking

Trunk
x86_64
All
Points:
---

Firefox Tracking Flags

(firefox50 affected)

Details

Attachments

(2 attachments)

Created attachment 8775173 [details]
screencast of the issue.mp4

[Affected versions]:
- Firefox 45 and up
- Activity Stream 1.1.1-dev

[Affected Platforms]:
- All Windows
- All Mac OS X
- All Linux

[Prerequisites]:
- Latest Activity Stream add-on (v1.1.1-dev) was previously installed on a clean profile.

[Steps to reproduce]:
1. Open the browser with the profile from prerequisites. 
2. Click on "+" to open a new tab.
3. Dismiss a few Trending articles from Highlights.
4. Close and restart the browser.

[Expected result]:
- The dismissed "Trending" articles are no longer displayed after the restart.

[Actual result]:
- The dismissed "Trending" articles are redisplayed in Highlights after the restart.

[Notes]:
- If all "Trending" articles are dismissed, the next number of fetched articles is not constant. Sometimes I got just 1 new article, sometimes I got more, but always the number was lower than the ones firstly displayed. 
- Also, when second batch is displayed, some of the articles are repeated even if they were previously dismissed.
- This issue is reproducible 5/5.
- A screen recording describing the issue was attached.

Comment 2

2 years ago
Hey! Can I take up this bug?
Hi Haard, I'm sorry but this is no longer of actuality since the Activity Stream team removed this functionality. 
Anyway, this issue was not on the browser itself, but on a separate platform where experimental features are tested. You can find out more details by visiting https://testpilot.firefox.com. You can contribute there in  some way if you want.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Comment 4

9 months ago
Created attachment 8973471 [details]
Firefox 60.0,1 on FreeBSD-CURRENT

Firefox 60, here's reappearance of a story that I dismissed earlier today. 

Can you reopen this bug? 

Thanks.

Comment 5

9 months ago
… dismissed twice, appeared three times now …

Comment 7

9 months ago
I haven't noticed the bug with any other story. However, my use of Firefox is infrequent (at the moment, it's almost solely for testing Activity Stream stuff) – I began testing these features only after I learnt of the sponsored content side of things. 

I wonder whether the bug will recur, with a different story, if I'm more aggressive with quits and starts of Firefox today. 

Side note: my perception of things may be clouded by bug 1459431, which is, in itself, puzzling (I have no idea whether it's proper for saved stories to reappear, repeatedly, as non-saved, and so on).
You need to log in before you can comment on or make changes to this bug.