Closed Bug 1289912 Opened 3 years ago Closed 3 years ago

Can't scroll in JSON Viewer in Nightly

Categories

(DevTools :: JSON Viewer, defect)

50 Branch
x86_64
All
defect
Not set

Tracking

(firefox49 unaffected, firefox50+ fixed, firefox51 verified, firefox52 unaffected)

VERIFIED FIXED
Firefox 51
Tracking Status
firefox49 --- unaffected
firefox50 + fixed
firefox51 --- verified
firefox52 --- unaffected

People

(Reporter: adamopenweb, Assigned: evanxd)

References

(Depends on 1 open bug)

Details

Attachments

(1 file)

STR:
1) Open nightly Firefox on desktop, tested in 50.0a1 (2016-07-27)
2) View some JSON, https://api.github.com/repos/webcompat/web-bugs/issues?state=open
3) Try to scroll with mouse or touchpad

Expected behavior:
Page scrolls

Actual behavior:
Doesn't scroll

Tested in OSX 10.11.6, Windows 10 and Ubuntu 16.04.
Assignee: nobody → evan
Hi Tim,

Could you help to review the patch?

Thanks.
Attachment #8776833 - Flags: review?(ntim.bugs)
Attachment #8776833 - Flags: review?(ntim.bugs) → review+
[Tracking Requested - why for this release]: Let's be sure to uplift since this breaking JSON Viewer for long data sets.
Pushed by ntim.bugs@gmail.com:
https://hg.mozilla.org/integration/fx-team/rev/555caa0082c3
Make JSON viewer content scrollable r=ntim
Status: NEW → ASSIGNED
https://hg.mozilla.org/mozilla-central/rev/555caa0082c3
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
I have reproduced this bug with Nightly 50.0a1 (2016-07-27) on Ubuntu 14.04, 64 bit!
The bug's fix is now verified on latest Nightly 51.0a1

Nightly 51.0a1:
Build ID 	20160804030441
User Agent 	Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
I have successfully reproduce this bug on firefox nightly 50.0a1 (2016-07-27)
with windows 7 (32 bit)
Mozilla/5.0 (Windows NT 6.1; rv:50.0) Gecko/20100101 Firefox/50.0

I found this fix on latest nightly 51.0a1 (2016-08-04)

Mozilla/5.0 (Windows NT 6.1; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID : 20160804030441

[bugday-20160803]
Based on comment 5 and comment 6 I will mark this accordingly.
Status: RESOLVED → VERIFIED
[Tracking Requested - why for this release]:
Duplicate of this bug: 1299879
Duplicate of this bug: 1303059
[Tracking Requested - why for this release]:

Reiterating jryan's tracking request from comment 2: Let's be sure to uplift since this breaking JSON Viewer for long data sets.
Hello Evan, should we uplift this fix to Beta50?
Flags: needinfo?(evan)
Hi Tim, should we uplift this fix to Beta50?
Flags: needinfo?(ntim.bugs)
Hi Ritu,

I think we can do that. This is just a small change.
Flags: needinfo?(evan)
Comment on attachment 8776833 [details] [diff] [review]
bug-1289912.patch



Approval Request Comment
[Feature/regressing bug #]:
[User impact if declined]: unscrollable jsonviewer
[Describe test coverage new/current, TreeHerder]: in 51/52
[Risks and why]: low , one line css change
[String/UUID change made/needed]: no
Flags: needinfo?(ntim.bugs)
Attachment #8776833 - Flags: approval-mozilla-beta?
Comment on attachment 8776833 [details] [diff] [review]
bug-1289912.patch

Fix was verified on Nightly51, let's uplift to Beta50.
Attachment #8776833 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Depends on: 1328009
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.