mozregression incorrectly bisects if there are only 2 pushes in the current range

RESOLVED INVALID

Status

RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: erahm, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
I was bisecting a warning regression and mozregression got down to this range with two pushes:
https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=ceb63dec9267e9bb62f5e5e1f4c9d32d3ac1fbac&tochange=c571462b1ff5e0d4661b9df4135b03febc81162c

It then decided that the second push (8c361c7cc683) was the 'first bad', when in fact it was the first push listed (c571462b1ff5).

It looks like the logic is a bit off, we return a midpoint for that range of 0 since it has less than 3 entries [1]. We then assume that we're finished because a midpoint of 0 is returned [2]. I haven't tracked down why it chose the second push over the first.

[1] https://github.com/mozilla/mozregression/blob/2928195c504e55423506b1f46f88818d2b95f5f2/mozregression/build_range.py#L144-L149
[2] https://github.com/mozilla/mozregression/blob/98971833d9642aa02ebceb4324d7f6a94f5b9138/mozregression/bisector.py#L364-L366
(Reporter)

Comment 1

2 years ago
It looks like I was misreading the log output. If there's a problem it's not what I've described here.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.