firefox not working with kde/plasma on gentoo linux

RESOLVED WORKSFORME

Status

()

Core
Graphics
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Daiajo, Unassigned, NeedInfo)

Tracking

47 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.82 Safari/537.36

Steps to reproduce:

After upgrading to KDE-plasma, started firefox 45.2.0
The upgraded to 47.0.1 (latest but still marked unstable)
Konqueror & chromium are working fine.


Actual results:

Firefox comes up with normal starting tabs quickly, but can take 5 minutes or more to load them.
during this time the other tabs are unresponsive & the address bar flashes between the new tab message (something like enter address or search expression) and the actual address its trying to  load. If another window is placed over Firefox, then removed, the area under the moved window takes several minutes to redraw. If Firefox is left running too long my machine hangs.
top shows nothing noticeable, there isn't excessive CPU usage.
The same symptoms occur for both versions I tried.


Expected results:

Firefox was working fine until I upgraded KDE to the plasma version,
it should have worked the same after the update.
(Reporter)

Updated

2 years ago
Severity: normal → critical
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

2 years ago
I updated to version 47.0.1 and this one is much better but still unusable.
A restore pages came up so I turned off all but 1 page (cookieclicker, a javascript idle game),
and it loaded after about 3 minutes.
However the screen is still flickering and the animations are very slow.
After clicking close window is took 1 minute to respond.
The flicking address bar has gone.

Updated

2 years ago
Component: Untriaged → Graphics
Product: Firefox → Core
Andrew would probably be able to comment on this
Can you please share the "Graphics" section of your about:support? Thanks!
Flags: needinfo?(daiajo)
(Reporter)

Comment 4

2 years ago
I am not sure I understand the requests.
This is my GPU from lspci:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Turks XT [Radeon HD 6670/7670]
I'm using ait-drivers, which is the fglrx module.

I can't access about:support as it won't respond, I can't type an address.
(Reporter)

Comment 5

2 years ago
After many attemps, firefox has come up, is responding, and so I got this from about:support, graphics
Graphics
Adapter Description	ATI Technologies Inc. -- AMD Radeon HD 6670
Asynchronous Pan/Zoom	none
Device ID	AMD Radeon HD 6670
Driver Version	4.5.13399 Compatibility Profile Context 15.302
GPU Accelerated Windows	1/1 OpenGL (OMTC)
Supports Hardware H264 Decoding	No
Vendor ID	ATI Technologies Inc.
WebGL Renderer	ATI Technologies Inc. -- AMD Radeon HD 6670
windowLayerManagerRemote	true
AzureCanvasAccelerated	0
AzureCanvasBackend	cairo
AzureContentBackend	cairo
AzureFallbackCanvasBackend	none
CairoUseXRender	0
Great, thank you! Can you try running with a fresh profile? By closing firefox and launching with:

> firefox --ProfileManager

you'll have the option to create a new profile.

I noticed you have OpenGL layers acceleration enabled; if creating a new profile works, can you test if enabling layers acceleration causes it to break again?
(Reporter)

Comment 7

2 years ago
The new profile creation worked normally.
During the firefox account creation though, firefox appeared to hang, but did respond eventually if I waited several minutes. Got though the account creation then firefox did hang.
I did breifly get the about:support up, and it looked the same as before.
I'm not sure which setting is layers acceleration, if is the "GPU Accelerated Windows" that is the same.

I don't know how to disable/enable layers acceleration anyway.
Interesting; layers acceleration isn't yet enabled by default in the builds shipped by Mozilla. I assume you're using the version of Firefox provided by your distribution then; can you please share your distribution information (name, release/version, etc)?

It would be interesting to see if the official builds at https://www.getfirefox.com work for you.
Ah, forget the first part; I forgot the title of the bug :) Still, trying the official builds would be worth a shot.
(Reporter)

Comment 10

2 years ago
Downloading the one from getfirefox, probably won't be able to test today as going out soon.
firefox seems stable if I just stick with about pages.
(Reporter)

Comment 11

2 years ago
Oh forgot to say if this version works, I'll raise a bug against gentoo.
Great, thanks. I took a look at the Gentoo ebuild for www-client/firefox; as I expected, the default USEFLAGS bundle prefs with layers.acceleration.force-enabled set by default.

If layers acceleration is at fault, it's still worth investigating here- we hope to enable it by default in the near future.
Hi Daiajo, I will close this issue as Resolved-Works for me. When you create the new issue for Gentoo you can reference this bug number if needed. Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 14

2 years ago
This is the gentoo bug https://bugs.gentoo.org/show_bug.cgi?id=590716
You need to log in before you can comment on or make changes to this bug.