Closed Bug 1290019 Opened 3 years ago Closed 3 years ago

fatal error in configure.py with Windows 10 Insider SDK due to failure to detect Manifest Tool version

Categories

(Firefox Build System :: General, defect)

Unspecified
Windows 10
defect
Not set

Tracking

(firefox47 unaffected, firefox48 unaffected, firefox49 unaffected, firefox50 fixed)

RESOLVED FIXED
mozilla50
Tracking Status
firefox47 --- unaffected
firefox48 --- unaffected
firefox49 --- unaffected
firefox50 --- fixed

People

(Reporter: jfkthame, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

See bug 1289294 comment 6:

> This seems to have broken my build on Windows 10 (Insider build), where the
> mt.exe I have does not report any version number. Previously, it looks like
> failure to read the MT version would issue a warning, but continue; now, it's
> a fatal configure-time error. :(

and the following comments. Prior to moving MT detection to python, I was able to build successfully; failure to detect a version number for the tool didn't actually break anything.

Note that the Insider version of the Win10 SDK (bug 1289294 comment 10) is essentially a "preview" of what we can expect with the Windows 10 Anniversary Update, due for general release in August IIRC.
$ ls -l "/c/Program Files (x86)/Windows Kits/10/Include"
total 0
drwxr-xr-x 3 jkew Administrators 0 May 11 21:48 10.0.10150.0
drwxr-xr-x 6 jkew Administrators 0 May 11 23:55 10.0.10240.0
drwxr-xr-x 6 jkew Administrators 0 May 11 23:14 10.0.10586.0
drwxr-xr-x 6 jkew Administrators 0 May 12 12:04 10.0.14332.0

FWIW, bug 1289294 comment 10 indicates that :m_kato has a slightly later build of the Insider SDK (10.0.14383.0), but hits the same issue with it.
Before bug 1289294, the impossibility to find the version of MT was only
issuing a warning. Warnings in configure are essentially useless, so
since we weren't and still aren't doing anything with the result of that
check, and since there are versions of MT that don't print out a version
number, just remove the check.

Review commit: https://reviewboard.mozilla.org/r/67674/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/67674/
Attachment #8775496 - Flags: review?(cmanchester)
Comment on attachment 8775496 [details]
Bug 1290019 - Remove MT version check.

https://reviewboard.mozilla.org/r/67674/#review64908
Attachment #8775496 - Flags: review?(cmanchester) → review+
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/b722fac1af4b
Remove MT version check. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/b722fac1af4b
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.