Closed Bug 1290026 Opened 3 years ago Closed 3 years ago

Automatically set INCLUDE and LIB from configure

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(firefox50 fixed, firefox51 fixed)

RESOLVED FIXED
mozilla50
Tracking Status
firefox50 --- fixed
firefox51 --- fixed

People

(Reporter: glandium, Assigned: glandium)

References

(Blocks 1 open bug)

Details

Attachments

(2 files)

No description provided.
Depends on: 1269517
No longer depends on: 1269517
With those two patches + what already landed from the dependencies, I was able to build from start-shell.bat with MSVC 2015u3 and Windows SDK 8.1. I was also able to build from start-shell.bat with Visual C++ build tools (just the compiler suite from MSVC, without the IDE) and Windows SDK 10, which is interesting because the start-shell-msvc* scripts don't work in that case.

As is, this is expected to break on landing, unless the msvc tooltool package is updated per bug 1289638.
Blocks: 1290040
Comment on attachment 8775490 [details]
Bug 1290026 - Automatically set INCLUDE from configure.

https://reviewboard.mozilla.org/r/67668/#review64904
Attachment #8775490 - Flags: review?(cmanchester) → review+
Comment on attachment 8775491 [details]
Bug 1290026 - Automatically set LIB from configure.

https://reviewboard.mozilla.org/r/67670/#review64906
Attachment #8775491 - Flags: review?(cmanchester) → review+
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/autoland/rev/a4a381f85dc8
Automatically set INCLUDE from configure. r=chmanchester
https://hg.mozilla.org/integration/autoland/rev/90559af62774
Automatically set LIB from configure. r=chmanchester
https://hg.mozilla.org/mozilla-central/rev/a4a381f85dc8
https://hg.mozilla.org/mozilla-central/rev/90559af62774
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla50
backed this out in https://treeherder.mozilla.org/#/jobs?repo=mozilla-central&revision=465d150bc8be5bbf9f02a8607d4552b6a5e1697c since one this 2 bugs caused issues on windows xp spidermonkey builds like https://treeherder.mozilla.org/logviewer.html#?job_id=32982163&repo=mozilla-inbound#L879
Status: RESOLVED → REOPENED
Flags: needinfo?(mh+mozilla)
Resolution: FIXED → ---
Backout by cbook@mozilla.com:
https://hg.mozilla.org/mozilla-central/rev/ca6285618c89
Backed out changeset 90559af62774 
https://hg.mozilla.org/mozilla-central/rev/a9d6bdcdb18d
Backed out changeset a4a381f85dc8
Pushed by mh@glandium.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/880f40a0a832
Automatically set INCLUDE from configure. r=chmanchester
https://hg.mozilla.org/integration/mozilla-inbound/rev/24ba1412f0dc
Automatically set LIB from configure. r=chmanchester
Depends on: 1291140
Flags: needinfo?(mh+mozilla)
https://hg.mozilla.org/mozilla-central/rev/880f40a0a832
https://hg.mozilla.org/mozilla-central/rev/24ba1412f0dc
Status: REOPENED → RESOLVED
Closed: 3 years ago3 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1318041
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.