Invalid height of MathML in HTML5

RESOLVED DUPLICATE of bug 1208776

Status

()

Core
MathML
P2
normal
RESOLVED DUPLICATE of bug 1208776
11 months ago
11 months ago

People

(Reporter: panzan89, Unassigned)

Tracking

({regression})

44 Branch
x86_64
Linux
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 months ago
Created attachment 8775593 [details]
mathml.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160606114208

Steps to reproduce:

Please test this HTML file: http://oss.arxitics.com/test/mathml.html



Actual results:

The height of inline math is 108px in my browser (see the attachment).


Expected results:

The inline math should have a proper height by default.
(Reporter)

Updated

11 months ago
Component: Untriaged → MathML
Product: Firefox → Core
(Reporter)

Updated

11 months ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64

Comment 1

11 months ago
Created attachment 8775608 [details]
Capture d’écran 2016-07-28 à 17.48.23.png

Height is normal on my side (FF47 Win 7 x32).
Reproduces in 44, not in 37.

The font switched from STIX General to Latin Modern Math.
I have Version 1.958 installed from texlive-fontsrecommended 2014.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression
Priority: -- → P2
Version: 47 Branch → 44 Branch

Comment 3

11 months ago
The font from TeX Live 2014 is rather old and most likely have the wrong font metrics.
This is a bug in Ubuntu, please move discussion there: https://bugs.launchpad.net/ubuntu/+source/lmodern/+bug/1502701
It seems that the latest version still did not take changes from Debian's testing.
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208776
You need to log in before you can comment on or make changes to this bug.