Weekly jobs scheduled with Airflow should have the run date set at the end of the week

RESOLVED FIXED

Status

Cloud Services
Metrics: Pipeline
P2
normal
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: rvitillo, Assigned: sunahsuh)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

User Story

The run date of a job is currently set by Airflow to the beginning of the period, which in case of a weekly job is 7 days behind the EOW. Ideally the run date should be set to the EOW in order to reduce lag.

Attachments

(1 attachment)

Comment hidden (empty)
Blocks: 1290155

Updated

2 years ago
Points: --- → 1
Priority: -- → P2
(Reporter)

Updated

2 years ago
Duplicate of this bug: 1306453
(Assignee)

Updated

2 years ago
Assignee: nobody → ssuh
(Assignee)

Updated

2 years ago
Depends on: 1309622
Created attachment 8800889 [details] [review]
[telemetry-airflow] mozilla:fix-weekly-execution-date > mozilla:master
(Assignee)

Updated

2 years ago
No longer depends on: 1309622
(Assignee)

Comment 3

2 years ago
The solution worked except the date's off by one (should add 6, not 7 days) -- new bug filed for that issue (https://bugzilla.mozilla.org/show_bug.cgi?id=1310715) so closing this one as resolved.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Blocks: 1312420
No longer blocks: 1312420
You need to log in before you can comment on or make changes to this bug.