Closed Bug 1290182 Opened 5 years ago Closed 5 years ago

The hovered 'x' icons on the control center panel look out of place on Mac

Categories

(Firefox :: General, defect)

defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: florian, Unassigned)

References

Details

(Whiteboard: [fxprivacy])

Attachments

(1 file)

When hovered, the 'x' icons added in bug 1203292 are in a gray circle. This reminds me of touch UIs but doesn't match anything we already have on Mac.

It also seems strange to me that the X icons are bolder than the icons on tabs.
The current implementation matches the mockup at http://people.mozilla.org/~shorlander/mockups-interactive/panel-mockups/panel-control-center.html
but the x icons on https://mozilla.invisionapp.com/share/AF71R266U#/screens/169430699 are lighter.
Note that we're planning to use similarly styled buttons for the Downloads Panel, there is a visual design spec in bug 1269956. The "cancel" button will look the same as this one, and it will also look the same on all platforms, this was just discussed last week with Stephen Horlander.

I guess we need to start implementing the new styles somewhere. We can surely make adjustments to the shape and size of the 'x' icon based on the visual designers input, but we should make sure to test on non-HiDPI too.
Whiteboard: [fxprivacy][triage]
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WONTFIX
Whiteboard: [fxprivacy][triage] → [fxprivacy]
My understanding is that the large round (x) button was added for the tab close button on Windows 8/10+ because of devices like the Surface which have touch screens. That (x) isn't used on Windows 7 or OS X for the tab close button. It feels out of place on OS X so are you sure that was intended?
Flags: needinfo?(shorlander)
It is intended and is similar to the button styling we currently use in the Downloads panel, e.g.: https://cl.ly/030E2L1d2V1F

This control is a little odd in that it's specific to the Control Center. There are other treatments we could explore but the important thing some visual feedback for the buttons.


(In reply to Florian Quèze [:florian] [:flo] from comment #0)
> It also seems strange to me that the X icons are bolder than the icons on
> tabs.
> The current implementation matches the mockup at
> http://people.mozilla.org/~shorlander/mockups-interactive/panel-mockups/
> panel-control-center.html
> but the x icons on
> https://mozilla.invisionapp.com/share/AF71R266U#/screens/169430699 are
> lighter.

I think I pulled the X icons from one of Bryan's files. If that's different than the delivered assets I would use the delivered assets. Unifying the cancel/close X glyph would be great! But I am waiting on bug 1058040 before I attempt that.
Flags: needinfo?(shorlander)
You need to log in before you can comment on or make changes to this bug.