Closed Bug 1290289 Opened 3 years ago Closed 3 years ago

1,700 instances of "NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4" emitted from netwerk/protocol/http/nsCORSListenerProxy.cpp during linux64 debug testing

Categories

(Core :: Networking, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1286036

People

(Reporter: erahm, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [necko-next])

> 0 NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4: file netwerk/protocol/http/nsCORSListenerProxy.cpp, line 553

This warning [1] shows up in the following test suites:


It shows up in 0 tests. A few of the most prevalent:


[1] https://hg.mozilla.org/mozilla-central/annotate/9ec789c0ee5b/none#l0
That should have been:

> 1726 WARNING: NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4: file netwerk/protocol/http/nsCORSListenerProxy.cpp, line 553

This warning [1] shows up in the following test suites:

>    636 - desktop-test-linux64/debug-mochitest-6 6
>    636 - desktop-test-linux64/debug-mochitest-e10s-6 6
>     95 - desktop-test-linux64/debug-mochitest-e10s-5 5
>     95 - desktop-test-linux64/debug-mochitest-5 5
>     74 - desktop-test-linux64/debug-web-platform-tests-e10s-4 4
>     74 - desktop-test-linux64/debug-web-platform-tests-4 4
>     31 - desktop-test-linux64/debug-web-platform-tests-3 3
>     31 - desktop-test-linux64/debug-web-platform-tests-e10s-3 3
>     16 - desktop-test-linux64/debug-mochitest-e10s-2 2
>     16 - desktop-test-linux64/debug-mochitest-2 2
>      9 - desktop-test-linux64/debug-mochitest-7 7
>      4 - desktop-test-linux64/debug-web-platform-tests-e10s-2 2
>      4 - desktop-test-linux64/debug-web-platform-tests-2 2
>      2 - desktop-test-linux64/debug-web-platform-tests-9 9
>      2 - desktop-test-linux64/debug-web-platform-tests-e10s-9 9
>      1 - desktop-test-linux64/debug-mochitest-e10s-7 7

It shows up in 50 tests. A few of the most prevalent:

>    212 -        dom/tests/mochitest/fetch/test_fetch_cors_sw_reroute.html
>    212 -        dom/tests/mochitest/fetch/test_fetch_cors_sw_empty_reroute.html
>    212 - [e10s] dom/tests/mochitest/fetch/test_fetch_cors_sw_empty_reroute.html
>    212 - [e10s] dom/tests/mochitest/fetch/test_fetch_cors_sw_reroute.html
>    201 -        dom/tests/mochitest/fetch/test_fetch_cors.html
>    201 - [e10s] dom/tests/mochitest/fetch/test_fetch_cors.html
>     59 -        dom/security/test/cors/test_CrossSiteXHR.html
>     59 - [e10s] dom/security/test/cors/test_CrossSiteXHR.html
>     40 - [e10s] /fetch/api/cors/cors-redirect-credentials.html
>     40 -        /fetch/api/cors/cors-redirect-credentials.html

[1] https://hg.mozilla.org/mozilla-central/annotate/9ec789c0ee5b/netwerk/protocol/http/nsCORSListenerProxy.cpp#l553
Summary: 0 instances of "NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4: file netwerk/protocol/http/nsCORSListenerProxy.cpp, line 553" emitted from none during linux64 debug testing → 1,700 instances of "NS_ENSURE_SUCCESS(status, status) failed with result 0x805303F4" emitted from netwerk/protocol/http/nsCORSListenerProxy.cpp during linux64 debug testing
Whiteboard: [necko-next]
Is this the same as bug 1286036?
Flags: needinfo?(erahm)
(In reply to Gary Chen [:xeonchen] from comment #2)
> Is this the same as bug 1286036?

Looks like it is.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(erahm)
Resolution: --- → DUPLICATE
Duplicate of bug: 1286036
You need to log in before you can comment on or make changes to this bug.