No other action should be performed when rearranging the tabs

VERIFIED FIXED

Status

()

Firefox for iOS
General
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: SimonB, Assigned: Nathanael Alcock)

Tracking

unspecified
All
iOS
Dependency tree / graph

Firefox Tracking Flags

(fxios-v5.0 affected, fxios-v6.0 verified, fxios6.0+)

Details

Attachments

(1 attachment)

48 bytes, text/x-github-pull-request
sleroux
: review+
Details | Review | Splinter Review
(Reporter)

Description

2 years ago
Build: 5e2ef3fb
Device: iPad Air 2
iOS: 9.3.3

Steps to reproduce:
1. Launch Firefox
2. Open tabs tray
3. Long tap on a tab to change it's position
4. While holding the finger on the tab, tap the menu button

Actual results:
- While holding the finger on the tab the user can navigate through the menu, settings access all the subsections. This can cause the application to crash in several locations (e.g. when deleting logins, when switching to private browsing).

Expected results: 
- No other action should be performed when rearranging the tabs (open/close tab, open menu, switch to private browsing).
(Assignee)

Updated

2 years ago
Assignee: nobody → nalcock
(Assignee)

Comment 1

2 years ago
Created attachment 8776039 [details] [review]
Pull request
Attachment #8776039 - Flags: review?(sleroux)
(Assignee)

Updated

2 years ago
Blocks: 1290443
Comment on attachment 8776039 [details] [review]
Pull request

Works for me!
Attachment #8776039 - Flags: review?(sleroux) → review+
master 12970feabee34ed2ddd410a27792ada82f7031b7
Status: NEW → RESOLVED
Last Resolved: 2 years ago
status-fxios-v6.0: --- → fixed
Resolution: --- → FIXED
tracking-fxios: ? → 6.0+
(Reporter)

Comment 4

2 years ago
Tested on master bd689d7e33 on devices running iOS 9.x and 10.0.3.  

No other action can be performed when rearranging the tabs (open/close tab, open menu, switch to private browsing).
Status: RESOLVED → VERIFIED
status-fxios-v6.0: fixed → verified
You need to log in before you can comment on or make changes to this bug.