Firefox crashes after losing connection and reconnecting

RESOLVED DUPLICATE of bug 1275518

Status

()

RESOLVED DUPLICATE of bug 1275518
2 years ago
2 years ago

People

(Reporter: samy.sadi.contact, Unassigned)

Tracking

51 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8776028 [details]
stacktrace.txt

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160728030208

Steps to reproduce:

Open firefox and some webpages.
Disable wifi for instance.
Reactivate wifi after 2 or 3 minutes.

Using archlinux x86_64 with xfce.



Actual results:

Firefox crashes after a small delay (some seconds). 

On console I see this:
console.error: PushService: 
  stateChangeProcessEnqueue: Error transitioning state
  UnknownError
console.error: 
  Error in asyncStorage.setItem(): 
console.error: 
  Error in asyncStorage.setItem(): 
console.error: 
  Error in asyncStorage.setItem(): 
ExceptionHandler::GenerateDump cloned child 8940
ExceptionHandler::SendContinueSignalToChild sent continue signal to child
ExceptionHandler::WaitForContinueSignal waiting for continue signal...
[Child 6652] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-l64-ntly-000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 2056
[Child 6652] ###!!! ABORT: Aborting on channel error.: file /builds/slave/m-cen-l64-ntly-000000000000000/build/src/ipc/glue/MessageChannel.cpp, line 2056
(Reporter)

Updated

2 years ago
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
(Reporter)

Updated

2 years ago
Has STR: --- → yes
is crash reporter enabled on your build?
if so, can you provide crash report?  that will give us some more info for the backtrace, especially symbols.
Flags: needinfo?(samy.sadi.contact)
(Reporter)

Comment 2

2 years ago
The crash reporter is enabled.
However, for some strange reason I cannot reproduce the issue anymore (I suspect recent system update).

As a notice, I used to experience the issue for several months and very consistently after disconnections on previous versions too (i.e. 46 and 47, and then on 50).

Anyways, I will provide additional information as soon as I reproduce the issue.
(Reporter)

Updated

2 years ago
Version: 50 Branch → 51 Branch
(Reporter)

Comment 3

2 years ago
Here is the crash ID (note crash reported using ver. 51).

db57a5fe-e3aa-446b-9f02-1b63e2160806
the crash signature is reported only once.
If you have experienced the crash several times and reported them also, that's strange.
Flags: needinfo?(samy.sadi.contact)
(Reporter)

Comment 5

2 years ago
Believe me, I experience the same crash several times a week.

It's just that I reported it only now.
(In reply to Samy from comment #5)
> It's just that I reported it only now.

ah, that explains.

bug 1264853 and bug 1275518 might be related.
Component: Untriaged → DOM: IndexedDB
Product: Firefox → Core
Hi Bevis,
Do you have any ideas of this?
Flags: needinfo?(btseng)
The crash report of comment 4 looks related to bug 1275518.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(btseng)
Resolution: --- → DUPLICATE
Duplicate of bug: 1275518
You need to log in before you can comment on or make changes to this bug.