Wish: Highlight uncompatible characters in current character set

RESOLVED WONTFIX

Status

MailNews Core
Internationalization
--
enhancement
RESOLVED WONTFIX
16 years ago
3 years ago

People

(Reporter: 石庭豐 (Seak, Teng-Fong), Unassigned)

Tracking

({intl})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: intl)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:0.9.8+)
Gecko/20020130
BuildID:    20020130

 When we send or save a message, Mozilla will check if there's any uncompatible
character with the charset of the message.  That's very well done!  It would,
however, be even better if Mozilla could highlight those uncompatible characters
so that user can choose to
1) ignore the problem,
2) change the charset, or
3) change the character(s) so as to conform to the current charset (well, the
best would be that everyone use Unicode, but that's not the case unfortunately)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

16 years ago
Keywords: intl

Comment 1

16 years ago
cool suggestion for new feature. move to m1.2
Target Milestone: --- → mozilla1.2

Updated

16 years ago
Status: NEW → ASSIGNED

Comment 2

16 years ago
Later versions of MSWord do this in a preview window when saving as plain text.
It's very useful.

Updated

16 years ago
Target Milestone: mozilla1.2alpha → ---
(Reporter)

Comment 3

16 years ago
Could someone take a look at bug 153761 ?  It's still not yet confirmed more
than two months after I reported it and the bug is still there.

(Sorry for the off-topic since I didn't know what to do else.)
(Reporter)

Comment 4

14 years ago
Is this bug left in oblivion?
Product: MailNews → Core
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
QA Contact: ji → i18n

Updated

5 years ago
Assignee: nhottanscp → nobody
Status: ASSIGNED → NEW
Whiteboard: intl
We do silent fallback to UTF-8 in most cases.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

3 years ago
What if distant agent can't handle UTF-8?  There are still situation where Unicode is not used, unfortunately.  One example that pops up to my head is some (old?) BlackBerry which can't parse correctly UTF-8 mails!  OK, to all fairness, this is what happened:

I sent UTF-8 mails to my friend's Hotmail mailbox.  When the mails are opened, all non-ISO 5589 characters would become gibberish!  That means even non-ASCII Western European characters like é, ç, ñ are all gibberish!  It's sad but true.  So I got to be careful when I send mail to this friend.

This is a wish.  It's not a bug.  So WONTFIX doesn't really make sense.  Could we leave this wish open until it's implemented?
(In reply to 石庭豐 (Seak, Teng-Fong) from comment #6)
> What if distant agent can't handle UTF-8?

Thunderbird has defaulted to UTF-8 in email since TB 29 (or several months now); several other clients have also defaulted to UTF-8 mail, e.g., Apple's .Mail program or Google's GMail client. Of en-US mail, over half of all mail is labeled as UTF-8. There are some locales where it's not the norm (jp is by far the worst offender here), but, in general, UTF-8 support is basically universal these days.

> This is a wish.  It's not a bug.  So WONTFIX doesn't really make sense. 
> Could we leave this wish open until it's implemented?

WONTFIX means "if a patch is provided, it will not be accepted." That is very much the case for this feature request.
You need to log in before you can comment on or make changes to this bug.