Move multiple messages from IMAP to Local Folders fails and produces empty messages in Local Folders

UNCONFIRMED
Unassigned

Status

Thunderbird
Untriaged
UNCONFIRMED
a year ago
11 months ago

People

(Reporter: eric.descabanes, Unassigned)

Tracking

45 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160606114208

Steps to reproduce:

I'm using TB under Ubuntu 14.04.
I use TB with several IMAP accounts on multiple servers.
Every now and then i try to move email messages from IMAP servers to Local Folders. When i select multiple messages in an IMAP folder and drag-and-drop them to a Local Folder, every once in a while, TB keeps showing the messages as selected in the IMAP folder. After waiting for a long time (e.g. 30 min) i eventually restart TB, and i find that i have a corresponding amount of messages completely empty in the Local Folder.

I'm confused as to whether the messages were lost or if they were left on the IMAP server. Sorry.


Actual results:

In TB, i now have messages in my Local Folder with From = "-"
When i look in the file Mail/Local Folders/MyFolderName, i find e.g.:

From - Sat Mar 26 15:43:13 2016
X-Mozilla-Status: 0013
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 

From - Sat Mar 26 15:43:13 2016
X-Mozilla-Status: 0003
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 

From - Sat Mar 26 15:43:13 2016
X-Mozilla-Status: 0011
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 

From - Sat Mar 26 15:43:13 2016
X-Mozilla-Status: 0001
X-Mozilla-Status2: 00000000
X-Mozilla-Keys:                                                                                 

I've written a Perl script to check all my Local Folders for this. The problem has occurred 10 times for me for groups of anywhere between 2 and 51 messages (i'm assuming that the date showing up in "From -" line is the date of the attempted move).

 15 From - Sat Jul 30 04:46:xx 2016
 10 From - Thu Jun 23 22:45:xx 2016
 51 From - Thu Jun 23 04:46:xx 2016
 18 From - Thu May 19 06:13:xx 2016
 16 From - Sat May 07 03:07:xx 2016
 29 From - Sat May 07 02:05:xx 2016
  2 From - Sun Apr 24 20:18:xx 2016
  2 From - Sun Apr 24 19:28:xx 2016
 10 From - Thu Apr 07 21:35:xx 2016
  4 From - Sat Mar 26 15:43:xx 2016

At first i quickly read bug reports saying it may be a problem with MSF files so i didn't look into it immediately.



Expected results:

The messages should have been properly moved or i should have gotten an error message saying that the messages cannot be moved or that the IMAP server had some sort of problem. For sure, it should not produce emty messages in my Local Folder.

Comment 1

11 months ago
This happens when filters "Move Message to Folder" also.

Comment 2

11 months ago
Isn't this a duplicate of 763390?
(Reporter)

Comment 3

11 months ago
Yes, it seems to be the same problem as 763390 but here it occurs on Ubuntu 14.04.
Maybe that is why i missed it before opening this. Sorry.

Comment 4

11 months ago
763390 is marked Unconfirmed, despite several people having the problem. I'm having the problem on Ubuntu 16.10 and still getting the problem.
You need to log in before you can comment on or make changes to this bug.