Firefox slows down when playing Facebook videos in HTML5

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
a year ago
a year ago

People

(Reporter: Chamath Mc, Unassigned)

Tracking

47 Branch
Points:
---

Firefox Tracking Flags

(platform-rel ?)

Details

(Whiteboard: [platform-rel-Facebook])

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:47.0) Gecko/20100101 Firefox/47.0
Build ID: 20160623154057

Steps to reproduce:

1. Make sure that you are already logged into Facebook and its videos are playing in HTML5.

2. Go directly to the following URL and wait. It would automatically start to play.

3. Open a tool to check process stats for Firefox.


Actual results:

You may notice that Firefox is constantly increasing its memory usage with higher CPU usage. Firefox would slow down.


Expected results:

Firefox should not have slowed down.
(Reporter)

Comment 1

a year ago
A URL of a Facebook Video from the Offical Facebook Page (Sorry, I have missed this URL in the iniial report)

https://www.facebook.com/facebook/videos/vl.515712155263726/10154651089866729/

Comment 2

a year ago
I'm noticing this as well since today's update 50.0a1 (2016-07-30) x64 Nightly build

It seems to be affecting the keyboard and mouse especially with noticeable freezes.
I tested this with FF 48 release and I can't reproduce it. I followed the steps from description and my CPU goes up to 19%. I didn't encounter any keyboard and mouse problems. 

Can you please create a new profile, you have the steps here:https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles?redirectlocale=en-US&redirectslug=Managing-profiles#w_starting-the-profile-manager

Please test if the issue can be reproduced in the safe mode of Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode
Flags: needinfo?(chamathmc)

Comment 4

a year ago
I can reproduce this as of 51.0a1 (2016-08-05) on a fresh profile. These steps are simplest:
1) add some bookmarks menu to your toolbar (this isn't necessary to cause the issue - just this is the easiest way to demonstrate the symptoms)
2) start two instances of Firefox
3) in the first instance open the js console and start an infinite loop "while(true) { console.log("test") } - optionally you can load some js heavy page or start any html5 video player
4) in the 2nd instance, interact with the bookmark menu and observe 2-3+ second delays for the UI to react to mouse events

I took a couple of screen captures as well:
http://imgur.com/gallery/6lns1

The bookmark menu lag is one symptom. If you open a page with a textarea and try to type in it you will notice similar lag with keyboard input.

Comment 5

a year ago
My bad - I only just realized that the original bug here is against 47. I noticed this immediately after the Nightly build on 7/30. I'll create a separate issue.

Comment 6

a year ago
I created issue 1292722 for the trouble since the 7/30 build. I think Chamath's bug something different, likely fixed already.
(Reporter)

Comment 7

a year ago
I had re-created the issue in Firefox Safe Mode.
Flags: needinfo?(chamathmc)
Hi Gcowie,

Thanks for your comments, I tested again the issue with FF Nightly 51.0a1 (2016-08-07) following the steps from comment 4 but I can't reproduce it. I also saw the attached video but for me the behaviour is normal in both instances of Firefox.
Component: Untriaged → Bookmarks & History
platform-rel: --- → ?
Whiteboard: [platform-rel-Facebook]
Component: Bookmarks & History → General

Updated

a year ago
Component: General → Untriaged
Please re-open if you can reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.