implement message of the day

RESOLVED FIXED

Status

Socorro
Webapp
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: lonnen, Assigned: adrian)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

2 years ago
We often want to warn users of abnormal states. We can provide this by implementing a message of the day style warning -- a solid bar at the top of every page that is not animated or dismissable. It should be populated by the admin panel, and not display at all if there is no message.

bonus points:
* if we can set it to be 'info', 'warning', or 'critical', with different styles for each


I thought we had this on file somewhere. I'll dupe if I find it.
(Reporter)

Comment 1

2 years ago
Oh, additional bonus points if it shows up somehow in API responses. Would be nice for consumers to read from that that and know something is amiss.
(Reporter)

Updated

2 years ago
Duplicate of this bug: 943922
(Assignee)

Updated

2 years ago
Assignee: nobody → adrian

Comment 4

2 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/1b5870a29f9e46f3d58e7c87e458915672fd538b
Fixes bug 1290687 - Added a status message to all pages. (#3415)

* Fixes bug 1290687 - Added a status message to all pages.

* review comments

* upper case

* show several messages, added pagination to admin page

* remove disable link when disabled

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

2 years ago
Will suggested that we add the date to each status message, so that people have a good idea of the time context.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 7

2 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/c34bdeb390a7483e26c62618182d0d99d891bd01
bug 1290687 - .exists to check for status messages (#3419)

r=adngdb

Comment 9

2 years ago
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/fb3c8dcb1f2a66cfc2a9ee08b07038c2f5c28c21
Fixes bug 1290687 - Added a date to the status messages. (#3421)

* Fixes bug 1290687 - Added a date to the status messages.

* used time_tag filter everywhere, added tests, review comments

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Actually. On second thoughts I realize I don't like how the date is displayed. My reaction when I see the date before the message is that the date is *part of* the message. I noticed that in myself even though I'm knowledgeable of how it works :)
I think it's because it's so unusual to put a date before the headline text. 

Making a little followup and if you disagree, you win and you can close this bug.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.