Detecting device orientation on Samsung Tab A

RESOLVED INVALID

Status

developer.mozilla.org
Events
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: r.foss, Unassigned)

Tracking

Details

(Reporter)

Description

2 years ago
What did you do?
================
Went to site:
 
https://developer.mozilla.org/en-US/docs/Web/API/Detecting_device_orientation


What happened?
==============
The bouncing ball demo does not work. Also, the javascript code that I have written to capture deviceorientation events does not work. The demo and my code both work on Samsung s4 phone and iPad.

What should have happened?
==========================
The bouncing ball should move on titling tablet.

Sliders in my program move on tilting. Does not happen on Samsung Tab A.

Thanks for help!

Is there anything else we should know?
======================================
Which browser do you use to test on Samsung Tab A and Samsung s4?
Does the issue happen on multiple browsers?
Flags: needinfo?(r.foss)
(Reporter)

Comment 2

2 years ago
Thanks for the assistance!

I used Chrome and Firefox.

The model of the Samsung is P550

Richard Foss.
This model, right?
http://www.samsung.com/us/mobile/galaxy-tab/SM-P550NZAAXAR-specs

Does the model have Gyro sensor?
I don't see that in the specs.
(Reporter)

Comment 4

2 years ago
Yes, that is the correct model.

Oh no, I didn't think to check on the gyro sensor. Thank you so much for checking on that! I assumed that if the tablet responded to device orientation changes, moving in and out of landscape mode, then it would also respond to device orientation events. I need to do some reading!

How does the device respond to the orientation changes if it only has an accelerometer?
(Reporter)

Comment 5

2 years ago
Another big thank you from me! I have just loaded the Sensor Kinetics app and see that indeed, there is no Gyro sensor on the device. Thanks for pointing this out!
Thank you for confirmation :)

If the device doesn't have enough sensors to provide the information, and other applications also cannot get such information with OS API,
this won't be a bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(r.foss)
Resolution: --- → INVALID
Whiteboard: [specification][type:bug]
(Reporter)

Comment 7

2 years ago
Yes indeed, its not a bug. Thanks again!
You need to log in before you can comment on or make changes to this bug.