Search does not remember the last item search for using CTRL-F or F3

RESOLVED WORKSFORME

Status

Thunderbird
Untriaged
--
minor
RESOLVED WORKSFORME
a year ago
5 months ago

People

(Reporter: Arthur K., Unassigned)

Tracking

48 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:47.0) Gecko/20100101 Firefox/47.0 SeaMonkey/2.44
Build ID: 20160608085536

Steps to reproduce:

I updated to 48.0b1 from 45.2.0 and did a search (CTRL-F) in the message body of an email for a specific word.


Actual results:

When I normally search for an item in the message pane, the last searched term is still remembered and I normally press F3 to find it again. In 48.0b1, it no longer remembers the last searched item.


Expected results:

It should remember the last thing I searched for when pressing F3 or it should display the last searched item in the search field if CTRL-F is pressed.

Tested also with 47.0b2 which still behaves as it should.
This is working for me with a nightly build.
Did you test safe mode?
 https://support.mozilla.org/en-US/kb/safe-mode
(Reporter)

Comment 2

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #1)
> This is working for me with a nightly build.
> Did you test safe mode?
>  https://support.mozilla.org/en-US/kb/safe-mode

Same behavior in Safe Mode. Can you test on 48? Was waiting to see if it was still on 49.0b but it's not finished building or the win32 builds did not complete.
We don't have a released version 48 beta - it was never released, so you probably shouldn't be using it.
I suggest closing this, and if it reproduce is 49 then reopen it. There's no way to predict when 49.0b will be relased
(Reporter)

Comment 4

a year ago
Since 49.0b is out, it is still happenign there as well.
And if you go back to 45.x.0 it works?
Flags: needinfo?(thee.chicago.wolf)
(Reporter)

Comment 6

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #5)
> And if you go back to 45.x.0 it works?

Yup. Just tested with 45.0.4 and it works. Anything with this change in 51.0b which I see is being built?
Flags: needinfo?(thee.chicago.wolf)
(Reporter)

Comment 7

a year ago
(In reply to Arthur K. from comment #6)
> Yup. Just tested with 45.0.4 and it works. Anything with this change in
> 51.0b which I see is being built?

Same behavior in the 51.0b build.
Thanks for testing. 

I cannot reproduce using the 51.0b *candidate* on win7.  If I search for "4", change to different message, hit f3 - it finds "4"
Severity: normal → minor
(Reporter)

Comment 9

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #8)
> Thanks for testing. 
> 
> I cannot reproduce using the 51.0b *candidate* on win7.  If I search for
> "4", change to different message, hit f3 - it finds "4"

Any pref I can switch on or off to test? Anything in prefs.js I can look for?
I do not know of anything.  

If you reproduce in a new profile then the likelihood of being an actual bug is somewhat higher, and perhaps worth pursuing
(Reporter)

Comment 11

a year ago
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #10)
> I do not know of anything.  
> 
> If you reproduce in a new profile then the likelihood of being an actual bug
> is somewhat higher, and perhaps worth pursuing

Well, I did backup my profile and started a new one from scratch and the problem is still there.
(Reporter)

Comment 12

5 months ago
Somewhere along the line this must have gotten fixed. I'm testing with TB 55.0b2 and it seems to work again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.