If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Wide characters do not display in the title bar with correct encoding

VERIFIED DUPLICATE of bug 104320

Status

()

Core
Internationalization
VERIFIED DUPLICATE of bug 104320
16 years ago
16 years ago

People

(Reporter: Aaron B., Assigned: Roy Yokoyama)

Tracking

({intl})

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)
BuildID:    2002020406

With japanese support downloaded/installed... the page shows in the correct 
font and is readable.

The title bar has ??-??, etc.   The characters are no garbled, in an i18n 
sense, but just shown with the incorrect encoding.



Reproducible: Always
Steps to Reproduce:
1. download/install japanese support
2. go to www.asahi.com  (just an example... many more exist)
3. look on the left of  "- Mozilla."  You should see "??-??"

Actual Results:  You should see "??-??"

Expected Results:  shown that text in the correct character encoding.

Comment 1

16 years ago
Dupe of bug #128396 ???
(Reporter)

Comment 2

16 years ago
I don’t believe this is a dupe of bug #128396.  In that case, "blank titlebar 
for cyrillic text when locale is specified"...  the title text did not appear.  
In my bug's case, the text appeared (in the wrong characterset) as ?? ???.  In 
my i18n experience, the title data has not been corrupted, but is merely 
displayed incorrectly.

After installing Japanese support, whether or not you can read Japanese doesn’t 
matter.	If you visit www.asahi.com, look at the title bar, the text is ???-??.  
If you look at the source of the page, within the <title> tags, the correct 
Japanese is displayed.

If you would like me to test further, please let me know.

Comment 3

16 years ago
->i18n
Assignee: trudelle → yokoyama
Component: XP Apps → Internationalization
QA Contact: sairuh → ruixu

Updated

16 years ago
Keywords: intl
QA Contact: ruixu → ylong

Comment 4

16 years ago
We can display the title properly on native language system, e.g. Japanese page
title on Japanese system.

We are not able to disply strings in title bar on non-native system, this is an
old problem, e.g. a Chinese page title on US or JA system. 

We have bugs(bug 104320, bug 97671) for it.  I'm marking dup. for it.  Please
re-open if disagree.

*** This bug has been marked as a duplicate of 104320 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE

Comment 5

16 years ago
Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.