Closed Bug 1291000 Opened 3 years ago Closed 3 years ago

Local directory text box too long, causing half buttons in Account manager

Categories

(Thunderbird :: Account Manager, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 51.0

People

(Reporter: Tonnes, Assigned: aceman)

Details

Attachments

(2 files, 1 obsolete file)

Attached image AS RSS Local dir.png
Starting in 48a, the text box for Local directory has become a little longer when viewing Feed settings, causing the dialog width to be too small if its size is not wide enough. See screenshot, created with new profile.

This may however be intentional and only show up because the dialog width is just too small (by default / unresized) and not remembered - see bug 1290991.

While at it, I think "Local directory" could or even should be changed to use "Local folder" for obvious reasons.
Isn't this caused by the width of "tag prefix" field, from bug 1263878 ?

(In reply to Ton from comment #0)
> While at it, I think "Local directory" could or even should be changed to
> use "Local folder" for obvious reasons.

Bug 721332 .
Assignee: nobody → acelists
Status: NEW → ASSIGNED
(In reply to :aceman from comment #1)
> Isn't this caused by the width of "tag prefix" field, from bug 1263878 ?

You mean bug 1263873
Yes :) Can you see the problem on Windows on clean profile? I can't on Linux, as I have a wider font.
Then I would make a patch to test.
Yes, I see it too on Win 10.
Attached patch patch (obsolete) — Splinter Review
So the account manager has width defined in 'ch', and the feed subscription dialog in 'em'. Maybe it wasn't the best to have a large element in both of them sized in px. Let's try '35ch'. Or we can have a different width in each dialog (but we didn't want that in the mentioned bug where we introduced the width also to AM).
Attachment #8776748 - Flags: ui-review?(richard.marti)
Comment on attachment 8776748 [details] [diff] [review]
patch

Looks good. Could you look if you could add a overflow: auto; to let appear scrollbars when the AM is too small like we have on other panels?
Attachment #8776748 - Flags: ui-review?(richard.marti) → ui-review+
Attached patch patch v2Splinter Review
Good catch, thanks.
Attachment #8776748 - Attachment is obsolete: true
Attachment #8776987 - Flags: review?(alta88)
Attachment #8776987 - Flags: review?(alta88) → review+
Comment on attachment 8776987 [details] [diff] [review]
patch v2

a=me for suite changes
https://hg.mozilla.org/comm-central/rev/5d476d6dfe087743a2b6abf1593ff3aa6deb1035
Status: ASSIGNED → RESOLVED
Closed: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 51.0
You need to log in before you can comment on or make changes to this bug.