Closed Bug 1291277 Opened 4 years ago Closed 4 years ago

Don't show unsubmitted crash report notification on beta channel

Categories

(Firefox :: General, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 51
Tracking Status
firefox49 + verified
firefox50 --- verified
firefox51 --- verified

People

(Reporter: mconley, Assigned: mconley)

References

Details

Attachments

(1 file)

We currently show this notification on all channels except release.

In bug 1284628 comment 15, shorlander suggested we disable this on beta until we have a better understanding of our beta population.
We were displaying this notificaton on all channels except Release before,
but UX wants us to suppress this on Beta for now until we have a better
sense of our population on that channel.

Review commit: https://reviewboard.mozilla.org/r/68568/diff/#index_header
See other reviews: https://reviewboard.mozilla.org/r/68568/
Attachment #8776937 - Flags: review?(jaws)
Assignee: nobody → mconley
Status: NEW → ASSIGNED
Comment on attachment 8776937 [details]
Bug 1291277 - Don't show pending crash reports notification on Release or Beta channnels.

https://reviewboard.mozilla.org/r/68568/#review65676
Attachment #8776937 - Flags: review?(jaws) → review+
Pushed by mconley@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/48b29950cfc6
Don't show pending crash reports notification on Release or Beta channnels. r=jaws
[Tracking Requested - why for this release]:

Firefox 49 will be the first beta where this notification has the opportunity to be exposed. We should probably have it disabled before the first beta build if possible.
Comment on attachment 8776937 [details]
Bug 1291277 - Don't show pending crash reports notification on Release or Beta channnels.

Approval Request Comment
[Feature/regressing bug #]:

Bug 1269998

[User impact if declined]:

Users on the Beta channel might periodically notice a "You have unsubmitted crash reports" notification a few seconds after browser startup. This is something that UX doesn't want to display to the user's on the Beta channel for now.

[Describe test coverage new/current, TreeHerder]:

Manually tested this.

[Risks and why]: 

This is really low risk - we're just changing the logic that checks whether or not to scan for unsubmitted crash reports to skip itself if the user is on release or beta.

[String/UUID change made/needed]:

None.
Attachment #8776937 - Flags: approval-mozilla-beta?
Attachment #8776937 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/48b29950cfc6
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 51
Comment on attachment 8776937 [details]
Bug 1291277 - Don't show pending crash reports notification on Release or Beta channnels.

Polish UX behavior on beta channel. Take it in 50 aurora and 49 beta. Should be in 49 beta 2.
Attachment #8776937 - Flags: approval-mozilla-beta?
Attachment #8776937 - Flags: approval-mozilla-beta+
Attachment #8776937 - Flags: approval-mozilla-aurora?
Attachment #8776937 - Flags: approval-mozilla-aurora+
Track this as Firefox 49 will be the first beta where this notification will be exposed.
Flags: qe-verify+
This is verified fixed on 49.0b8-build1 (20160829102229) using Windows 10 x64,
Mac OS X 10.10.5 and Ubuntu 14.04 x86 - the "You have X unsubmitted crash
reports" infobar is no longer displayed on the beta channel.

Just to be safe, I've also made sure to check that the infobar is still
currently displayed on 50.0a2 (2016-08-31) and 51.0a1 (2016-08-31).

I'm not sure exactly how I could verify this bug fix on 50 and 51 without
actually waiting for these versions to enter beta. AFAICT, the fix for this bug
doesn't take into consideration the value of app.update.url (e.g. setting
51.0a1's update channel to beta will still show the infobar).

Mike, if you have any ideas on the matter, let me know. Otherwise, we'll have
to wait a while before this gets checked out on 50 and 51.
Flags: needinfo?(mconley)
(In reply to Andrei Vaida, QA [:avaida] – please ni? me from comment #12)

This bug alters the notification bar to ensure that we're in a non-release build (so Nightly or Aurora) before it considers checking for unsubmitted crash reports.

It sounds like you've verified this for 49. I suspect we can feel safe about assuming it will work then when 50 goes to beta, and 51, etc.
Flags: needinfo?(mconley)
Updating status accordingly, thank you for following up on this, Mike.
Status: RESOLVED → VERIFIED
This is verified fixed on 50.0b8-build1 (20161017130949) as well, using Windows 10 x64, Ubuntu 14.04 x86 and Mac OS X 10.11.6. The "You have X unsent crash reports" infobar is not displayed.
hi, after the update to 51.0b the requests to send unsubmitted crash reports are reappearing on the beta channel. is this by design (bug 1287178)?
Flags: needinfo?(mconley)
(In reply to [:philipp] from comment #16)
> hi, after the update to 51.0b the requests to send unsubmitted crash reports
> are reappearing on the beta channel. is this by design (bug 1287178)?

Yes, we're showing them for users on early betas since bug 1303067.

You can disable this via browser.crashReports.unsubmittedCheck.enabled, or even better, choose "Always" in the notification bar to always submit the backlogged crash reports (which is super helpful for us to make Firefox more stable) and never see the notification again.
Flags: needinfo?(mconley)
I reproduced this issue using Fx 51.0b2 (20161121093909) on Windows 10 x64 and Mac OS X 10.11. The "You have X unsubmitted crash reports." infobar is still displayed.
However this is expected until the early beta cycle is over. I will come back once Fx50.0b5 is available and verify the issue.

Cheers!
Flags: qe-verify+
[bugday-20170118] Bug verified
You need to log in before you can comment on or make changes to this bug.