Systematic popup error when starting Nightly 51.0a1

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
2 years ago
a year ago

People

(Reporter: richard.fortuno, Unassigned)

Tracking

51 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

504.02 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document
Details
493.51 KB, image/png
Details
(Reporter)

Description

2 years ago
Created attachment 8776964 [details]
Doc1.docx

User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/49.0.2623.112 Safari/537.36 OPR/36.0.2130.75

Steps to reproduce:

Launch the browser.


Actual results:

popup error appears.


Expected results:

Launching without popup error
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows XP
Hardware: Unspecified → x86
Created attachment 8777810 [details]
extracted image from Doc1.docx
Does the issue happen with safe mode and clean profile?
Flags: needinfo?(richard.fortuno)
(Reporter)

Comment 3

2 years ago
I do not know, I have not tried yet. But I'll do it when I get some time, I promise!
(Reporter)

Comment 4

2 years ago
A promise is due! I tried safe mode by default and clean profile. Unfortunately, "the duck is still alive" as we say here.
(Reporter)

Updated

2 years ago
Flags: needinfo?(richard.fortuno) → needinfo?(arai.unmht)
When have the problem started happening?  after update?
Does the issue happen with 48 (release), or is it nightly only issue?

If the issue happens only after some specific version, can you find out when the regression was introduced?
http://mozilla.github.io/mozregression/
Flags: needinfo?(arai.unmht)
(Reporter)

Comment 6

2 years ago
First of all, sorry for my poor English but I'm French (70 years old).

To be fair I did not take note when this problem has occurred. I think it was with the first version 50.xx that the phenomenon began. At first I did not attach great importance to the extent Nightly was operating anyway. I naively thought that the problem had already come to the ears of developers and were about fix here "two-pot spoon shot". But I see that here is slow and this problem is still there. Even if not annoying, here remains annoying.
(Reporter)

Comment 7

2 years ago
I think I understand what I have to do. I'll try the operation but no guarantee of the outcome, especially in the handling of the tool. He'll have to my some time!

Comment 8

2 years ago
I tested again this issue on Windows XP x86 with FF Nightly 51.0a1 (2016-08-23) and I can't reproduce the issue, I also tested with FF 48 release and the result is the same, can't reproduce the issue. 

 Richard did you have any luck with mozregression?
Flags: needinfo?(richard.fortuno)
(Reporter)

Comment 9

2 years ago
Hello Ovidiu,
At the moment I'm on vacation in the family far away from home. Probably I should go back in a fortnight.
But this is also the resumption of the hunting season (yes, I am hunter). It is therefore necessary that I find the time to invest in the research of the issue that still exists on my computer despite the latest updates of Nightly. As I already said, it does not stop to operate but it is very annoying.
I promise, I will find time to investigate as soon as can.

Updated

2 years ago
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit

Comment 10

2 years ago
helper.exe is an extra Firefox process that does some kind of Windows maintenance (though I don't understand exactly what it does). http://searchfox.org/mozilla-central/source/browser/components/shell/nsWindowsShellService.cpp#264

It almost certainly doesn't have separate crash reporting. Jim, you added this code long ago: do you have suggestions for what we should do next? Do we still need the helper process at all?
Flags: needinfo?(richard.fortuno) → needinfo?(jmathies)

Comment 11

2 years ago
(In reply to Benjamin Smedberg [:bsmedberg] from comment #10)
> helper.exe is an extra Firefox process that does some kind of Windows
> maintenance (though I don't understand exactly what it does).
> http://searchfox.org/mozilla-central/source/browser/components/shell/
> nsWindowsShellService.cpp#264
> 
> It almost certainly doesn't have separate crash reporting. Jim, you added
> this code long ago: do you have suggestions for what we should do next? Do
> we still need the helper process at all?

This is part of the NSIS updater, it does a lot of work revolving around elevation and such. 

That call to ShortcutMaintenance() is no longer needed so we could eliminate it, but there are some questions here -

1) the reporter says he is on XP, so helper.exe should never launch from ShortcutMaintenance() since there are checks to be sure we only execute this particular maintenance task on Win7 and up. Strong possibility that ShortcutMaintenance() has nothing to do with this crash.

2) helper.exe shouldn't have any issue launching on XP in general.

Rob, any ideas here?
Component: Startup and Profile System → Installer
Flags: needinfo?(jmathies) → needinfo?(robert.strong.bugs)
Product: Toolkit → Firefox
I'll take a look but I'm not sure why this errors.

Richard, do you get the same error when you run helper.exe by opening it from
<path to install directory>\uninstall\helper.exe

When you do that just exit after the user interface is displayed.
Flags: needinfo?(robert.strong.bugs) → needinfo?(richard.fortuno)
(Reporter)

Comment 13

2 years ago
:rstrong,

I have just returned from vacation and I take notice of your request.
I followed your instructions exactly in two stages:
1- Without nigthly start (only helper.exe)
2- With nigthly launched
In both cases, I got the same result: the application nigthly Uninstall launches and displays the interface "Welcome to nigthly Uninstall Wizard" appears. What seems okay!
Of course, I have not gone further because I have no idea what happens if I enable "next". I suppose it uninstalls nigthly.
In any event, the problem is not reproduced.I have just returned from vacation and I take notice of your request.
I followed your instructions exactly in two stages:
1- Without nigthly start (only helper.exe)
2- With nigthly launched
In both cases, I got the same result: the application nigthly Uninstall launches and displays the interface "Welcome to nigthly Uninstall Wizard" appears. What seems okay!
Of course, I have not gone further because I have no idea what happens if I enable "next". I suppose it uninstalls nigthly.
In any event, the problem is not reproduced.
Flags: needinfo?(richard.fortuno)
We no longer support Windows XP except under ESR; if this is still an issue on at least Windows 7, please file it again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.