Closed Bug 1291313 Opened 6 years ago Closed 6 years ago

nightly only shows accounts.firefox.com in about:logins but no menu or search

Categories

(Firefox for Android Graveyard :: Logins, Passwords and Form Fill, defect, P1)

defect

Tracking

(firefox48 ?, firefox49+ wontfix, firefox50+ unaffected, firefox51 unaffected)

RESOLVED WORKSFORME
Tracking Status
firefox48 --- ?
firefox49 + wontfix
firefox50 + unaffected
firefox51 --- unaffected

People

(Reporter: anaran, Unassigned)

Details

(Keywords: regressionwindow-wanted)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:51.0) Gecko/20100101 Firefox/51.0
Build ID: 20160802030437

Steps to reproduce:

Sign in to my fxaccount in nightly and perform full sync
I choose to sync logins, bookmarks, evereything
I perform full sync


Actual results:

Looking in
about:login
after entering my master password I only see
https://accounts.firefox.com
listed but

1. none of my other logins which show up fine in firefox beta for android on same device.

2. No menu appears when tapping the shown https://accounts.firefox.com login

3. The looking glass icon button does not bring up a search dialog (works in beta)


Expected results:

All three issues should not be present in nightly "51.0a1 (2016-08-02)" (and earlier versions) and features should work as well as they do in firefox beta for android
I'm on 51.0a1 (2016-08-04) and notice almost the same. To be honest, I don't know for sure what the expected behaviour is since I didn't check with Beta or release.

1) I have synced and I only see accounts.firefox.com show up
2) Clicking on "Tap here to check Sync settings" doesn't do anything
3) I don't see a looking glass icon button

Cheers,
Michael
[Tracking Requested - why for this release]: possible regression
Hi,

This might be a duplicate of bug 1290823, i had encountered this issue since several buttons become unresponsive following bug's 1290823 appearance.
Mihai, can you check if this really affects 49 or not?  It looks like bug 1290823 only affected up to 50.
Flags: needinfo?(mihai.ninu)
Hi Sebastian, this seems like a pretty core scenario. Can we get a dev owner to investigate? Thanks!
Flags: needinfo?(s.kaspari)
Do we have something describing this feature? I have no idea what accounts should be shown for this. The looking glass doesn't show up for me either, so we might need a better description here. I'd be happy to investigate if there is a documentwtion or bug or anything describing what the feature should look like.
tracking-fennec: --- → ?
Priority: -- → P1
The search icon works for me: A search box appears at the bottom of the screen and I can filter the list.

Unfortunately I can't add a new password because the doorhanger does not show up in my builds (bug 1297019, bug 1279924, bug 1287202).

There were two logins in my sync test account and they showed up on both test devices. However after editing one of them and syncing, it just disappeared on the other device (and was not updated). This seems to be broken - but I would like to see the behavior when adding a new password.


(In reply to Michael Kohler [:mkohler] from comment #6)
> Do we have something describing this feature? I have no idea what accounts
> should be shown for this. The looking glass doesn't show up for me either,
> so we might need a better description here. I'd be happy to investigate if
> there is a documentwtion or bug or anything describing what the feature
> should look like.

The list should contain all accounts for which you saved passwords in Firefox. After clicking on the search icon you can filter the list of accounts (To search 'Facebook' for example).
Flags: needinfo?(s.kaspari)
Should this block the fennec 49 release? I'm not clear how serious this is. 
Is it the normal behavior? Did we ever cover the case of multiple sync accounts? Or, is this something we may want to consider for future work, but not as a blocker for release now?
Flags: needinfo?(s.kaspari)
Flags: needinfo?(bbermes)
Hi, i could not reproduce the mentioned issue on 49.0b8, tested on a Nexus 7 with Android 5.1.1
Flags: needinfo?(mihai.ninu)
I did another test and everything's working as expected. Passwords are synchronized and I can filter them.

@anaran: Is this still happening for you?
Flags: needinfo?(s.kaspari)
Flags: needinfo?(adrian.aichner)
From talking with kevin today in the channel meeting it sounds like we don't need to track this in triage for 49 and it isn't a release blocker. Sebastian, leaving it to you to resolve for 51.  Please ask if you need more help from QE.
removing the NI as it seems to have been solved / appropriately triaged.
Flags: needinfo?(bbermes)
Looks like this seems to be working for people. Reopen if more information becomes available.
Status: NEW → RESOLVED
tracking-fennec: ? → ---
Closed: 6 years ago
Resolution: --- → WORKSFORME
Flags: needinfo?(adrian.aichner)
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.