Windows 10 start menu tile doesn't always use updated settings in firefox.VisualElementsManifest.xml

RESOLVED FIXED in Firefox 57

Status

()

defect
P1
normal
RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: jaws, Assigned: mhowell)

Tracking

Trunk
Firefox 57
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify -

Firefox Tracking Flags

(firefox51 affected, firefox57 fixed)

Details

(Whiteboard: [reserve-photon-animation])

Attachments

(1 attachment)

Summary: The installer needs to update the lastWriteTime of the Firefox startmenu shortcut for all users and the current user → Windows 10 start menu tile doesn't always use updated settings in firefox.VisualElementsManifest.xml. Fix is likely in comment #0
I guess we need to do something with auto-upgrade as well.
[Tracking Requested - why for this release]: in changing the Firefox icon, we should make sure that the updater clears the Windows Start Menu icon cache so the new icons will be used.
Whiteboard: [photon-animation] [triage]
I've just done some testing and it seems like the approach from bug 1284517 did not work; as in, the method it uses to update the last modified time does not actually affect the last modified time. We might be better off calling the SetFileTime API to update the time directly, or failing that we can just recreate the shortcut file.

Note that this does not make bug 1284517 comment 16 incorrect; we do still need to be doing this in both start menu locations.
SetFileTime appears to be working, I'll put up a patch that uses that.
Assignee: nobody → mhowell
Status: NEW → ASSIGNED
Priority: -- → P1
Summary: Windows 10 start menu tile doesn't always use updated settings in firefox.VisualElementsManifest.xml. Fix is likely in comment #0 → Windows 10 start menu tile doesn't always use updated settings in firefox.VisualElementsManifest.xml
Posted patch PatchSplinter Review
Attachment #8894644 - Flags: review?(robert.strong.bugs)
Attachment #8894644 - Flags: review?(robert.strong.bugs) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/e68e6723cff722c5e948ff8851bc589bda6a3be0
Bug 1291331 - Update last modified time on start menu shortcuts during install or update. r=rstrong
Flags: qe-verify?
Whiteboard: [photon-animation] [triage] → [reserve-photon-animation]

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e68e6723cff7
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Iteration: --- → 57.1 - Aug 15
Since this is fixed, no need to track it for 57.
Flags: qe-verify? → qe-verify-

Updated

2 years ago
Depends on: 1391910
Assignee

Updated

2 years ago
Duplicate of this bug: 1378142
You need to log in before you can comment on or make changes to this bug.